summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2011-08-13 00:45:20 +0200
committerDan McGee <dan@archlinux.org>2011-08-15 20:05:17 +0200
commit1741b5cc30119631940f7b471395765fb6fa7b0f (patch)
treed0bf6b100bbaf4cb1e70ba3a5f50bdb5ab7df99b /scripts/Makefile.am
parenta628feee46f2200db7d3303091813f050a61d0a3 (diff)
downloadpacman-1741b5cc30119631940f7b471395765fb6fa7b0f.tar.gz
pacman-1741b5cc30119631940f7b471395765fb6fa7b0f.tar.xz
dist: preserve symlinks on installation
This applies to the repo-remove man page as well as the script itself. Yes Dan, I ran distcheck afterwards. Signed-off-by: Dave Reisner <dreisner@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index adb259a7..b5767ac6 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -4,9 +4,7 @@ AUTOMAKE_OPTIONS = std-options
SUBDIRS = po
bin_SCRIPTS = \
- $(OURSCRIPTS) \
- repo-remove \
- repo-elephant
+ $(OURSCRIPTS)
OURSCRIPTS = \
makepkg \
@@ -105,4 +103,18 @@ repo-elephant: $(srcdir)/repo-add.sh.in
rm -f repo-elephant
$(LN_S) repo-add repo-elephant
+install-data-hook:
+ cd $(DESTDIR)$(bindir) && \
+ ( $(LN_S) repo-add repo-elephant || \
+ ln repo-add repo-elephant || \
+ cp repo-add repo-elephant )
+ cd $(DESTDIR)$(bindir) && \
+ ( $(LN_S) repo-add repo-remove || \
+ ln repo-add repo-remove || \
+ cp repo-add repo-remove )
+
+uninstall-hook:
+ cd $(DESTDIR)$(bindir) && \
+ $(RM) repo-remove repo-elephant
+
# vim:set ts=2 sw=2 noet: