summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2014-03-03 11:14:45 +0100
committerAllan McRae <allan@archlinux.org>2014-03-03 11:17:39 +0100
commit1afddd74a978631ff4f15d450b96d66e7af1e768 (patch)
tree994701e76dac778f4da0f322b26da3c2a99060aa /scripts/Makefile.am
parente6ff63076390141f2606babda627e5e053462456 (diff)
downloadpacman-1afddd74a978631ff4f15d450b96d66e7af1e768.tar.gz
pacman-1afddd74a978631ff4f15d450b96d66e7af1e768.tar.xz
Fix install order in scripts Makefile
We need to use install-exec-hook instead of install-data-hook to make sure the hook is run after the installation of the scripts into $BINDIR.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 5d69993e..43045df2 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -142,7 +142,7 @@ makepkg-wrapper: \
$(AM_V_at)chmod +x,a-w $@
$(AM_V_at)$(LN_S) makepkg-wrapper makepkg
-install-data-hook:
+install-exec-hook:
cd $(DESTDIR)$(bindir) && \
$(RM) makepkg makepkg-wrapper
$(INSTALL) .lib/makepkg $(DESTDIR)$(bindir)/makepkg