summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2012-12-16 13:32:54 +0100
committerAllan McRae <allan@archlinux.org>2013-01-03 03:03:10 +0100
commit241d6b884a3a6c883b6c61a3b175d17e7d317fc5 (patch)
tree0e45b5375174c4b1fceb5a00657875657fd4d793 /scripts/Makefile.am
parentd5a6ce8ca124d1eea343314b23110e006eb313d5 (diff)
downloadpacman-241d6b884a3a6c883b6c61a3b175d17e7d317fc5.tar.gz
pacman-241d6b884a3a6c883b6c61a3b175d17e7d317fc5.tar.xz
makepkg: use --apparent-size when du supports it
Amazingly, using "sleep 1" to convince btrfs to report correct file sizes is only a 90% fix. Sometimes more sleep is needed. Instead we use the --apparent-size argument to du to get actual file sizes. This is used only on Linux as the various BSDs do not support this argument. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 2bd64118..c3c1d73a 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -57,6 +57,7 @@ edit = sed \
-e "s|@INODECMD[@]|$(INODECMD)|g" \
-e 's|@SIZECMD[@]|$(SIZECMD)|g' \
-e 's|@SEDINPLACE[@]|$(SEDINPLACE)|g' \
+ -e 's|@DUFLAGS[@]|$(DUFLAGS)|g' \
-e 's|@DUPATH[@]|$(DUPATH)|g' \
-e 's|@SCRIPTNAME[@]|$@|g' \
-e 's|@configure_input[@]|Generated from $@.sh.in; do not edit by hand.|g'