summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-08-20 06:29:56 +0200
committerDan McGee <dan@archlinux.org>2008-08-20 06:29:56 +0200
commit282eeadc68fec1da8651d0c65ad0dfebd11a9c7f (patch)
tree1d3cf24273b8514c8ffa67e6d7d8b90fc876eb99 /scripts/Makefile.am
parent9609c0f1351a73e06edcfda1494a41d66c51dcb5 (diff)
downloadpacman-282eeadc68fec1da8651d0c65ad0dfebd11a9c7f.tar.gz
pacman-282eeadc68fec1da8651d0c65ad0dfebd11a9c7f.tar.xz
Factor shell script size command into configure script
Commit 149839c5391e9a93 introduced a small behavior regression as a drawback for a better portability. repo-add now includes the approximate size (to the nearest KB) rather than an exact size due to the switching of the du command to a more portable form. Instead of sacrificing the exact size, use configure to help us determine a valid command to acquire our filesize and place it in the sync database. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 7dccff9d..fd8fab7f 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -37,6 +37,7 @@ edit = sed \
-e 's|@PACKAGE_BUGREPORT[@]|$(PACKAGE_BUGREPORT)|g' \
-e 's|@PACKAGE_NAME[@]|$(PACKAGE_NAME)|g' \
-e 's|@DBEXT[@]|$(DBEXT)|g' \
+ -e 's|@SIZECMD[@]|$(SIZECMD)|g' \
-e 's|@configure_input[@]|Generated from $@.in; do not edit by hand.|g'
## All the scripts depend on Makefile so that they are rebuilt when the