summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2013-09-22 12:25:30 +0200
committerAllan McRae <allan@archlinux.org>2013-10-14 05:01:10 +0200
commit31a55df3d9750b2cdb21d436c4bf3ffbf24c4f4d (patch)
treeb08af369319dd8cb9f38dce4fb7c377b74ee7330 /scripts/Makefile.am
parentc9ab8a7f6c4d70672e2681f0e57d3298a2bdab7b (diff)
downloadpacman-31a55df3d9750b2cdb21d436c4bf3ffbf24c4f4d.tar.gz
pacman-31a55df3d9750b2cdb21d436c4bf3ffbf24c4f4d.tar.xz
makepkg: add LIBRARY variable
This points makepkg to where is library is located. Can be overridden by value in the environment. Signed-off-by: Allan McRae <allan@archlinux.org> [Ashley: Rebased] Signed-off-by: Ashley Whetter <ashley@awhetter.co.uk>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index f45065da..81307045 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -39,6 +39,8 @@ LIBRARY = \
# Files that should be removed, but which Automake does not know.
MOSTLYCLEANFILES = $(bin_SCRIPTS)
+libmakepkgdir = $(libdir)/makepkg
+
clean-local:
$(AM_V_at)$(RM) -r .lib
@@ -54,6 +56,7 @@ edit = sed \
-e 's|@localedir[@]|$(localedir)|g' \
-e 's|@sysconfdir[@]|$(sysconfdir)|g' \
-e 's|@localstatedir[@]|$(localstatedir)|g' \
+ -e 's|@libmakepkgdir[@]|$(libmakepkgdir)|g' \
-e 's|@pkgdatadir[@]|$(pkgdatadir)|g' \
-e 's|@prefix[@]|$(prefix)|g' \
-e '1s|!/bin/bash|!$(BASH_SHELL)|g' \