summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-02-22 22:34:51 +0100
committerDan McGee <dan@archlinux.org>2007-02-22 22:34:51 +0100
commit332c12710988198070fbc95cd869ca639b989238 (patch)
tree2dd7b1977f297bd660b26cef168325a347953384 /scripts/Makefile.am
parentef4728903d4c5f69100a0b3923b82b6008972c6f (diff)
downloadpacman-332c12710988198070fbc95cd869ca639b989238.tar.gz
pacman-332c12710988198070fbc95cd869ca639b989238.tar.xz
Big commit here, I'll try to cover all the bases.
* Updated all of the language files, as the POT file was updated. NOTE FOR TRANSLATORS, try to base your next contribution off of these, notice how some msgids and messages have been wrapped to the next line- it makes it easier to read anyway. * More Makefile.am/configure.ac updates. 'make dist' and 'make distclean' now work properly, with only one caveat- the automatic testing in distclean doesn't do so hot as it is compiled with a default configure, which includes the fakeroot-proof code (which does not cooperate with pactest). * Added a Makefile.am for the pactest directory.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 31d44cad..9592cb4f 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,4 +1,6 @@
-AUTOMAKE_OPTIONS = std-options
+# TODO: this would be nice to enable, but we need --help and --version
+# flags on all of our scripts first (this is what it checks)
+#AUTOMAKE_OPTIONS = std-options
bin_SCRIPTS = \
abs \
@@ -12,4 +14,6 @@ bin_SCRIPTS = \
re-pacman \
updatesync
+EXTRA_DIST = $(bin_SCRIPTS)
+
abs gensync makepkg makeworld pacman-optimize rankmirrors repo-add repo-remove re-pacman updatesync: