summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2010-10-14 00:50:54 +0200
committerDan McGee <dan@archlinux.org>2010-10-14 00:50:54 +0200
commit6eedf06fcc224648155bc5253d6fe1975be8da00 (patch)
tree98ab83ec4927766ba88f2bbf819a59a5d8cb9f35 /scripts/Makefile.am
parenta7dc3875f15f9600e011c313c8846de6af3a2c8c (diff)
downloadpacman-6eedf06fcc224648155bc5253d6fe1975be8da00.tar.gz
pacman-6eedf06fcc224648155bc5253d6fe1975be8da00.tar.xz
Fix bash shell location check
BASH is defined when you are actually using bash during configure, which sucks because it ends up being '/bin/sh', messing up all of our scripts. Change the name of the variable we use in configure, and also ensure we get a full path to the executable by using AC_PATH_PROGS rather than AC_CHECK_PROGS. Finally, change the variable name everywhere we use it. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index b9e3038f..78deb0b9 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -35,7 +35,7 @@ edit = sed \
-e 's|@sysconfdir[@]|$(sysconfdir)|g' \
-e 's|@localstatedir[@]|$(localstatedir)|g' \
-e 's|@prefix[@]|$(prefix)|g' \
- -e 's|@BASH[@]|$(BASH)|g' \
+ -e 's|@BASH_SHELL[@]|$(BASH_SHELL)|g' \
-e 's|@PACKAGE_VERSION[@]|$(REAL_PACKAGE_VERSION)|g' \
-e 's|@PACKAGE_BUGREPORT[@]|$(PACKAGE_BUGREPORT)|g' \
-e 's|@PACKAGE_NAME[@]|$(PACKAGE_NAME)|g' \