summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-05-07 00:27:43 +0200
committerDan McGee <dan@archlinux.org>2012-06-26 06:39:34 +0200
commita98fce08968febe7395b30f15f070f400da089ed (patch)
tree419123b22846a05a0eda74db324b6d3741208539 /scripts/Makefile.am
parentab8431c92953c4562af214e5170f8ef321037108 (diff)
downloadpacman-a98fce08968febe7395b30f15f070f400da089ed.tar.gz
pacman-a98fce08968febe7395b30f15f070f400da089ed.tar.xz
scripts/library: add size_to_human
This function is the reverse of human_to_size, and converts integer byte sizes to human readable SI prefixed values. A logical extension of this might be to mimic the formatter that pacman uses and allow a second argument to be passed in which can coerce the size, rather than reducing until the unit count is below 1024. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 75699b2e..29c81aa5 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -28,7 +28,8 @@ EXTRA_DIST = \
LIBRARY = \
library/output_format.sh \
library/parseopts.sh \
- library/human_to_size.sh
+ library/human_to_size.sh \
+ library/size_to_human.sh
# Files that should be removed, but which Automake does not know.
MOSTLYCLEANFILES = $(bin_SCRIPTS)