summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorAlad Wenter <alad@archlinux.info>2016-10-08 19:34:15 +0200
committerAllan McRae <allan@archlinux.org>2016-10-22 12:50:28 +0200
commitaca153bfa6b1bcd828f0b35db453bb9fea6a08bf (patch)
tree336ea9ce88241d65fd55f2affcabab439c9d1c76 /scripts/Makefile.am
parent8c55c0096c355e973ce6111cb25a1c4fa05953cf (diff)
downloadpacman-aca153bfa6b1bcd828f0b35db453bb9fea6a08bf.tar.gz
pacman-aca153bfa6b1bcd828f0b35db453bb9fea6a08bf.tar.xz
libmakepkg: generate all scripts
In order for the scripts to be used in testsuites, it is easiest to generate all of them so they are found in the build directory (which may be different to the source directory). Signed-off-by: Alad Wenter <alad@archlinux.info> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 92cd50cd..5d4fd29e 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,6 +1,10 @@
# enforce that all scripts have a --help and --version option
AUTOMAKE_OPTIONS = std-options
-AM_INSTALLCHECK_STD_OPTIONS_EXEMPT = makepkg-wrapper
+AM_INSTALLCHECK_STD_OPTIONS_EXEMPT = \
+ makepkg-wrapper \
+ pacman-db-upgrade-wrapper \
+ pacman-key-wrapper \
+ pkgdelta-wrapper
SUBDIRS = po
@@ -47,11 +51,6 @@ LIBMAKEPKGDIRS = \
tidy \
util
-LIBMAKEPKG = \
- libmakepkg/util/message.sh \
- libmakepkg/util/option.sh \
- libmakepkg/util/util.sh
-
LIBMAKEPKG_IN = \
libmakepkg/integrity.sh \
libmakepkg/integrity/generate_checksum.sh \
@@ -96,11 +95,13 @@ LIBMAKEPKG_IN = \
libmakepkg/tidy/strip.sh \
libmakepkg/tidy/zipman.sh \
libmakepkg/util.sh \
+ libmakepkg/util/message.sh \
+ libmakepkg/util/option.sh \
libmakepkg/util/pkgbuild.sh \
- libmakepkg/util/source.sh
+ libmakepkg/util/source.sh \
+ libmakepkg/util/util.sh
LIBMAKEPKG_DIST = \
- $(LIBMAKEPKG) \
$(addsuffix .in, $(LIBMAKEPKG_IN))
COMPLETION_IN = \