summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2011-12-25 10:58:31 +0100
committerDan McGee <dan@archlinux.org>2011-12-29 05:32:22 +0100
commitb264fb9e9ddcc31dc8782390309421965e507383 (patch)
treec65f39987e25cc7552e0282d8b0ad125a88624ff /scripts/Makefile.am
parent1b461374264abd62c54133e544dedd5feb866043 (diff)
downloadpacman-b264fb9e9ddcc31dc8782390309421965e507383.tar.gz
pacman-b264fb9e9ddcc31dc8782390309421965e507383.tar.xz
makepkg: calculate exact total file size
The current calculation of the total file size for a package using "du" suffers from issues in portability and correctness. Especially on btrfs, this can result in clearly wrong package information such as: Download Size : 14684.29 KiB Installed Size : 7628.00 KiB Use an approach based on "stat" to calculate total file size. Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 328fbff2..727de258 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -53,7 +53,6 @@ edit = sed \
-e 's|@BUILDSCRIPT[@]|$(BUILDSCRIPT)|g' \
-e 's|@SIZECMD[@]|$(SIZECMD)|g' \
-e 's|@SEDINPLACE[@]|$(SEDINPLACE)|g' \
- -e 's|@DUPATH[@]|$(DUPATH)|g' \
-e 's|@SCRIPTNAME[@]|$@|g' \
-e 's|@configure_input[@]|Generated from $@.sh.in; do not edit by hand.|g'