summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-04-26 04:27:19 +0200
committerDan McGee <dan@archlinux.org>2012-06-26 06:39:12 +0200
commitb58489d29a1898a4bff1b5da6ca4bfb14003dbfe (patch)
tree5c42f704cc671136ef43972cfdee1274e620e65f /scripts/Makefile.am
parente183522e3168c4a31103b3c7910fa8d29333fb5a (diff)
downloadpacman-b58489d29a1898a4bff1b5da6ca4bfb14003dbfe.tar.gz
pacman-b58489d29a1898a4bff1b5da6ca4bfb14003dbfe.tar.xz
scripts/library: add human_to_size
This is a bash wrapper around an awk function that parses human readable sizes and returns their representative values in bytes, as a string. A small test harness is added to validate the functionality. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 6bb72198..75699b2e 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -27,7 +27,8 @@ EXTRA_DIST = \
LIBRARY = \
library/output_format.sh \
- library/parseopts.sh
+ library/parseopts.sh \
+ library/human_to_size.sh
# Files that should be removed, but which Automake does not know.
MOSTLYCLEANFILES = $(bin_SCRIPTS)