summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-08-24 01:27:01 +0200
committerDan McGee <dan@archlinux.org>2008-10-13 04:36:30 +0200
commitf1f8f0e1c291a2201f122e0ec1d7e6179bf11cc8 (patch)
treea477553fcc0b8427d5aaf81b6c65a144ce13cded /scripts/Makefile.am
parentda933c223eedb66c51b4a48b6ab0ce8fcb344b5c (diff)
downloadpacman-f1f8f0e1c291a2201f122e0ec1d7e6179bf11cc8.tar.gz
pacman-f1f8f0e1c291a2201f122e0ec1d7e6179bf11cc8.tar.xz
Quiet up the make process a bit
When we do our sed edits, we really don't need every command printed out to the terminal. Now with "make -s", the output is quite palatable. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index fd8fab7f..014ae870 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -46,13 +46,14 @@ edit = sed \
# two 'test' lines- make sure we can handle both sh and py type scripts
# third 'test' line- make sure one of the two checks succeeded
$(OURSCRIPTS): Makefile
- rm -f $@ $@.tmp
- test -f $(srcdir)/$@.sh.in && $(edit) $(srcdir)/$@.sh.in >$@.tmp || true
- test -f $(srcdir)/$@.py.in && $(edit) $(srcdir)/$@.py.in >$@.tmp || true
- test -f $@.tmp || false
- chmod +x $@.tmp
- chmod a-w $@.tmp
- mv $@.tmp $@
+ @echo ' ' GEN $@;
+ @rm -f $@ $@.tmp
+ @test -f $(srcdir)/$@.sh.in && $(edit) $(srcdir)/$@.sh.in >$@.tmp || true
+ @test -f $(srcdir)/$@.py.in && $(edit) $(srcdir)/$@.py.in >$@.tmp || true
+ @test -f $@.tmp || false
+ @chmod +x $@.tmp
+ @chmod a-w $@.tmp
+ @mv $@.tmp $@
makepkg: $(srcdir)/makepkg.sh.in
pacman-optimize: $(srcdir)/pacman-optimize.sh.in