summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-11-05 05:05:44 +0100
committerDan McGee <dan@archlinux.org>2007-11-06 04:10:22 +0100
commit11f99e06850a7d1242d3dc6427f52eee32256e63 (patch)
treed59708aac64d96215f2b1f6a0cef7562c11994df /src/pacman/Makefile.am
parent0686fec8399e01adacd1633d6ad624ee2d5b6d9c (diff)
downloadpacman-11f99e06850a7d1242d3dc6427f52eee32256e63.tar.gz
pacman-11f99e06850a7d1242d3dc6427f52eee32256e63.tar.xz
Add LOGFILE as a define at compile time for pacman
It has always been a bit odd that logfile had to be specified in the config file, but no other paths did. Add LOGFILE as a preprocessor definition, and make a call to alpm_option_set_logfile() to set the default location so no logfile parameter is necessary in pacman.conf. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index d0b727f6..0395432e 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -2,6 +2,7 @@
conffile = ${sysconfdir}/pacman.conf
dbpath = ${localstatedir}/lib/pacman/
cachedir = ${localstatedir}/cache/pacman/pkg/
+logfile = ${localstatedir}/log/pacman.log
bin_PROGRAMS = pacman
@@ -14,6 +15,7 @@ DEFS = -DLOCALEDIR=\"@localedir@\" \
-DROOTDIR=\"$(ROOTDIR)\" \
-DDBPATH=\"$(dbpath)\" \
-DCACHEDIR=\"$(cachedir)\" \
+ -DLOGFILE=\"$(logfile)\" \
@DEFS@
INCLUDES = -I$(top_srcdir)/lib/libalpm