summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-07-23 22:58:04 +0200
committerDan McGee <dan@archlinux.org>2007-07-23 22:58:04 +0200
commit178c1d228d5b910908e16f9c3715e318d6df4882 (patch)
tree286ded2341992af4bbcad295a8bf4f06015e68c2 /src/pacman/Makefile.am
parentea9a756eeaca7398c0860b55f8abe2932ad195bd (diff)
downloadpacman-178c1d228d5b910908e16f9c3715e318d6df4882.tar.gz
pacman-178c1d228d5b910908e16f9c3715e318d6df4882.tar.xz
Cleanup of pacman.c and addition of default paths to frontend
Instead of barfing when the root path and db path haven't been defined, have pacman set them to some sane defaults when they aren't specified on either the command line or the config file. Also do some cleaning of error output and Doxygen comments. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 589ac63c..d997ecc6 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -1,10 +1,13 @@
# paths set at make time
conffile = ${sysconfdir}/pacman.conf
+dbpath = ${localstatedir}/lib/pacman/
bin_PROGRAMS = pacman pacman.static
DEFS = -DLOCALEDIR=\"@localedir@\" \
-DCONFFILE=\"$(conffile)\" \
+ -DROOTDIR=\"$(ROOTDIR)\" \
+ -DDBPATH=\"$(dbpath)\" \
@DEFS@
INCLUDES = -I$(top_srcdir)/lib/libalpm