summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2012-05-04 04:07:50 +0200
committerAllan McRae <allan@archlinux.org>2012-12-14 04:45:12 +0100
commit18ddf90ff41a9de6611400065b18f6de8dc35b01 (patch)
treec51ae8a6ba27140ac876b1ba67ca01f621c202db /src/pacman/Makefile.am
parent097d5a478b32aece93013580fdb06cacbaf0e9a0 (diff)
downloadpacman-18ddf90ff41a9de6611400065b18f6de8dc35b01.tar.gz
pacman-18ddf90ff41a9de6611400065b18f6de8dc35b01.tar.xz
Move check function into its own file
There is going to be a lot of overlap in the code for the quick and full checks that can be abstracted into their own functions. Also many other file checking functions will be needed for the full check. Put all these in a separate source file. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index d296d485..311f7c5b 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -27,6 +27,7 @@ AM_CPPFLAGS += -DGIT_VERSION=\"$(GIT_VERSION)\"
endif
pacman_SOURCES = \
+ check.h check.c \
conf.h conf.c \
database.c \
deptest.c \