summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2013-01-03 11:49:33 +0100
committerAllan McRae <allan@archlinux.org>2013-01-04 12:49:37 +0100
commit27d9c25ee2fd6a03fb1ec1afdfbe105048875bae (patch)
treec5f6739e5f72a153fb358b2702965c39352ef630 /src/pacman/Makefile.am
parent965e1de2174148a7a6c0860a7514d9bb1969bf03 (diff)
downloadpacman-27d9c25ee2fd6a03fb1ec1afdfbe105048875bae.tar.gz
pacman-27d9c25ee2fd6a03fb1ec1afdfbe105048875bae.tar.xz
Split common utility functions for libalpm and pacman
There is duplicated code in the util.c files in the libalpm and pacman source code. Split this into a separate file so that it can be shared via a symlink. This prevents code divergence between the two code bases. Also, move mbasename and mdirname from pacman/util.c into util-common.c in preparation for the following patch that uses them to add an extension to pacsave files. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 311f7c5b..ed515739 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -38,7 +38,8 @@ pacman_SOURCES = \
sync.c \
callback.h callback.c \
upgrade.c \
- util.h util.c
+ util.h util.c \
+ util-common.h util-common.c
LDADD = $(LTLIBINTL) $(top_builddir)/lib/libalpm/.libs/libalpm.la