summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-09-19 05:38:21 +0200
committerAllan McRae <allan@archlinux.org>2012-11-27 06:16:15 +0100
commit40d68949100d534e4dea766c7f8f60ed36aa4429 (patch)
tree855a3987b41b01724e575fdb9e91d1d1caee85c2 /src/pacman/Makefile.am
parent768c8ba100f1bdef9bb99f8ca619d23f055877ce (diff)
downloadpacman-40d68949100d534e4dea766c7f8f60ed36aa4429.tar.gz
pacman-40d68949100d534e4dea766c7f8f60ed36aa4429.tar.xz
buildsys: eschew use of DEFS, prefer AM_CPPFLAGS
This is redundant, and any usage of -D should belong to CPPFLAGS. Signed-off-by: Dave Reisner <dreisner@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index c8ce9773..d296d485 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -9,23 +9,21 @@ logfile = ${localstatedir}/log/pacman.log
bin_PROGRAMS = pacman
-DEFS = -DLOCALEDIR=\"@localedir@\" \
- -DCONFFILE=\"$(conffile)\" \
- -DDBPATH=\"$(dbpath)\" \
- -DGPGDIR=\"$(gpgdir)\" \
- -DCACHEDIR=\"$(cachedir)\" \
- -DLOGFILE=\"$(logfile)\" \
- @DEFS@
-
AM_CPPFLAGS = \
-imacros $(top_builddir)/config.h \
- -I$(top_srcdir)/lib/libalpm
+ -I$(top_srcdir)/lib/libalpm \
+ -DLOCALEDIR=\"@localedir@\" \
+ -DCONFFILE=\"$(conffile)\" \
+ -DDBPATH=\"$(dbpath)\" \
+ -DGPGDIR=\"$(gpgdir)\" \
+ -DCACHEDIR=\"$(cachedir)\" \
+ -DLOGFILE=\"$(logfile)\"
AM_CFLAGS = -pedantic -D_GNU_SOURCE $(WARNING_CFLAGS)
if USE_GIT_VERSION
GIT_VERSION := $(shell sh -c 'git describe --abbrev=4 --dirty | sed s/^v//')
-DEFS += -DGIT_VERSION=\"$(GIT_VERSION)\"
+AM_CPPFLAGS += -DGIT_VERSION=\"$(GIT_VERSION)\"
endif
pacman_SOURCES = \