summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2015-11-30 18:36:30 +0100
committerAllan McRae <allan@archlinux.org>2015-12-05 09:09:39 +0100
commit4d2317dafb3c3aac56f9f604262d82fd1b396a19 (patch)
treefcc34638f1c0d75c523a237a8c58aec219b72c1a /src/pacman/Makefile.am
parent220a3ce2b8177bb3cc8a7a20715b67d5cbf7fc71 (diff)
downloadpacman-4d2317dafb3c3aac56f9f604262d82fd1b396a19.tar.gz
pacman-4d2317dafb3c3aac56f9f604262d82fd1b396a19.tar.xz
move signal handlers to sighandler.[ch]
Signals are special because they run asynchronously, making them non-trivial to handle correctly. Move the handlers a separate file to offset them from the normal code and make them easier to separate into individual functions without further cluttering pacman.c Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index b07c6706..14572cd4 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -40,6 +40,7 @@ pacman_SOURCES = \
pacman.h pacman.c \
query.c \
remove.c \
+ sighandler.h sighandler.c \
sync.c \
callback.h callback.c \
upgrade.c \