summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorNagy Gabor <ngaba@petra.hos.u-szeged.hu>2007-06-10 23:51:20 +0200
committerDan McGee <dan@archlinux.org>2007-06-11 04:13:58 +0200
commit544bcbe6641bb94a429a9c149893bc0b07fd2619 (patch)
tree7e88da506f5c1269a8014688c08b4bec63505eb9 /src/pacman/Makefile.am
parent8588b4823b579bc41909734f5a13a420d64487d6 (diff)
downloadpacman-544bcbe6641bb94a429a9c149893bc0b07fd2619.tar.gz
pacman-544bcbe6641bb94a429a9c149893bc0b07fd2619.tar.xz
Implement simple topological sort algorithm for sortbydeps
Based on the "depth first search" algorithm, for more infos visit: http://en.wikipedia.org/wiki/Topological_sorting The previous algorithm used by sortbydeps was too slow, and to work around it the number of steps needed to get correct result was reduced greatly. So it produced wrong results in several cases : 1) smoke001.py 2) http://bugs.archlinux.org/task/7229 More here: http://archlinux.org/pipermail/pacman-dev/2007-April/008057.html Signed-off-by: Chantry Xavier <shiningxc@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 6a7f4e43..1ab59166 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -26,11 +26,11 @@ pacman_SOURCES = \
util.h util.c
pacman_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la \
- -ldownload
+ -ldownload -lm
pacman_static_SOURCES = $(pacman_SOURCES)
pacman_static_LDFLAGS = $(LDFLAGS) -all-static
pacman_static_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la \
- -ldownload
+ -ldownload -lm
# vim:set ts=2 sw=2 noet: