summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2015-10-17 02:28:27 +0200
committerAllan McRae <allan@archlinux.org>2015-10-18 02:59:23 +0200
commit7000bf919812f3ed56969a86b4aebf90e98ec6a3 (patch)
tree0cbf71072c97a77a5a65d8f15c7b508f078313d5 /src/pacman/Makefile.am
parente8e872c8f93ba13f67b882d64c16606973f0ff67 (diff)
downloadpacman-7000bf919812f3ed56969a86b4aebf90e98ec6a3.tar.gz
pacman-7000bf919812f3ed56969a86b4aebf90e98ec6a3.tar.xz
pacman: add user hook directories
Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index d3ae071e..b07c6706 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -4,6 +4,7 @@ SUBDIRS = po
conffile = ${sysconfdir}/pacman.conf
dbpath = ${localstatedir}/lib/pacman/
gpgdir = ${sysconfdir}/pacman.d/gnupg/
+hookdir = ${sysconfdir}/pacman.d/hooks/
cachedir = ${localstatedir}/cache/pacman/pkg/
logfile = ${localstatedir}/log/pacman.log
@@ -16,6 +17,7 @@ AM_CPPFLAGS = \
-DCONFFILE=\"$(conffile)\" \
-DDBPATH=\"$(dbpath)\" \
-DGPGDIR=\"$(gpgdir)\" \
+ -DHOOKDIR=\"$(hookdir)\" \
-DCACHEDIR=\"$(cachedir)\" \
-DLOGFILE=\"$(logfile)\"