summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-03-31 05:26:32 +0200
committerDave Reisner <dreisner@archlinux.org>2012-04-09 04:28:45 +0200
commit793eff37047dbceedaf3443311bc826566685181 (patch)
treed55886e67e13f347e483d0c30dd005f1aaee1fac /src/pacman/Makefile.am
parent7fcb445f35d70d6dd4fa14e9d7b5de35625b0811 (diff)
downloadpacman-793eff37047dbceedaf3443311bc826566685181.tar.gz
pacman-793eff37047dbceedaf3443311bc826566685181.tar.xz
buildsys: define warning CFLAGS in separate var
Continue the trend of not touching the environment CFLAGS, ensuring that the user always has the final say. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 9a92fd6b..c8ce9773 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -21,7 +21,7 @@ AM_CPPFLAGS = \
-imacros $(top_builddir)/config.h \
-I$(top_srcdir)/lib/libalpm
-AM_CFLAGS = -pedantic -D_GNU_SOURCE
+AM_CFLAGS = -pedantic -D_GNU_SOURCE $(WARNING_CFLAGS)
if USE_GIT_VERSION
GIT_VERSION := $(shell sh -c 'git describe --abbrev=4 --dirty | sed s/^v//')