summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-12-02 21:14:14 +0100
committerDan McGee <dan@archlinux.org>2008-03-08 21:13:34 +0100
commit797c190f93d24ff1e352549f320a0612cd04382b (patch)
tree4d65a987204fd9c11f93be7ba8dd8b1b6a492ac6 /src/pacman/Makefile.am
parent3ec45486ff1373f9f65af229af315219fc1f0f7e (diff)
downloadpacman-797c190f93d24ff1e352549f320a0612cd04382b.tar.gz
pacman-797c190f93d24ff1e352549f320a0612cd04382b.tar.xz
Remove frontend add code that is no longer necessary
Change the pacman_upgrade stub function to do what pacman_add used to do so we can eliminate pacman_add. Move the code to the more-descriptive name of upgrade.c. Note that we have made no changes to the backend libalpm, where an ADD type transaction could still be supported. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 0395432e..fbb50a29 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -22,7 +22,6 @@ INCLUDES = -I$(top_srcdir)/lib/libalpm
AM_CFLAGS = -pedantic -D_GNU_SOURCE
pacman_SOURCES = \
- add.c \
conf.h conf.c \
deptest.c \
package.h package.c \
@@ -31,6 +30,7 @@ pacman_SOURCES = \
remove.c \
sync.c \
callback.h callback.c \
+ upgrade.c \
util.h util.c
pacman_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la