summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorAaron Griffin <aaron@archlinux.org>2007-01-18 17:52:57 +0100
committerAaron Griffin <aaron@archlinux.org>2007-01-18 17:52:57 +0100
commit86b136bb592bf576a3da950fee153f6d4f5b9d15 (patch)
treef6289e427de5c5b2cfd3e3d37b75fc9506eb3bdb /src/pacman/Makefile.am
parent46e26ac5c8d15fbb2385ad972f2f69891a0bd8d0 (diff)
downloadpacman-86b136bb592bf576a3da950fee153f6d4f5b9d15.tar.gz
pacman-86b136bb592bf576a3da950fee153f6d4f5b9d15.tar.xz
Dan McGee <dpmcgee@gmail.com>
* Removed some unnecessary headers and library links * Made things static if possible * Cleaned up makefiles a bit * Fixed some old comments in the code * Fixed some errors the static code checker splint pointed out * Backwards arguments in a memset call in _alpm_db_read (could have been worse) * Other various small fixes Other: * Default to 80 columns when getcols cannot determine display width * Removal of ._install as a valid install file in packages
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 129fbee5..d637dc2d 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -17,9 +17,9 @@ pacman_SOURCES = util.c log.c list.c package.c downloadprog.c trans.c add.c \
pacman_static_SOURCES = $(pacman_SOURCES)
pacman_LDADD = -L$(top_srcdir)/lib/libalpm/.libs \
- -ldownload -larchive -lm -lalpm -lssl -lcrypto
+ -ldownload -lm -lalpm
pacman_static_LDADD = -L$(top_srcdir)/lib/libalpm/.libs/ \
- -ldownload -larchive -lm -lalpm -lssl -lcrypto
+ -ldownload -lm -lalpm
pacman_static_LDFLAGS = $(LDFLAGS) -all-static