summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-07-16 02:05:24 +0200
committerDan McGee <dan@archlinux.org>2008-07-16 02:05:24 +0200
commit95995ae93f90faab2f4c9fe59ea95167d20c88de (patch)
tree112a033461b4be9686abdd51a1a357eae9a5f136 /src/pacman/Makefile.am
parent874190827676e3a974e8c5fef6c51b9e9d6b60fa (diff)
downloadpacman-95995ae93f90faab2f4c9fe59ea95167d20c88de.tar.gz
pacman-95995ae93f90faab2f4c9fe59ea95167d20c88de.tar.xz
Remove pacman.static build from build files
This presents plenty of problems on OSes besides Linux, and even on Linux when the libtool file for libarchive isn't present. The static build isn't all that useful anyway as missing something such as glibc will still leave you unable to run the pacman.static binary. Remove it from the formal build process. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index e5f8cb36..220ee9cb 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -6,10 +6,6 @@ logfile = ${localstatedir}/log/pacman.log
bin_PROGRAMS = pacman
-if INCLUDE_PACMAN_STATIC
-bin_PROGRAMS += pacman.static
-endif
-
DEFS = -DLOCALEDIR=\"@localedir@\" \
-DCONFFILE=\"$(conffile)\" \
-DROOTDIR=\"$(ROOTDIR)\" \
@@ -40,7 +36,4 @@ pacman_SOURCES = \
LDADD = $(LTLIBINTL) $(top_builddir)/lib/libalpm/.libs/libalpm.la
-pacman_static_SOURCES = $(pacman_SOURCES)
-pacman_static_LDFLAGS = $(LDFLAGS) -all-static
-
# vim:set ts=2 sw=2 noet: