summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorNagy Gabor <ngaba@bibl.u-szeged.hu>2009-05-20 21:46:23 +0200
committerDan McGee <dan@archlinux.org>2010-05-05 17:37:01 +0200
commitac9dde072c56b9dbc3fe515dc3702c2c992f492f (patch)
tree1a600dc9a1a5a06af0eb1b60507ea7551f0a2e8f /src/pacman/Makefile.am
parent6b6eb6345bb3d9f59d967144968328c9a4b7873c (diff)
downloadpacman-ac9dde072c56b9dbc3fe515dc3702c2c992f492f.tar.gz
pacman-ac9dde072c56b9dbc3fe515dc3702c2c992f492f.tar.xz
Introduce -D, --database
The request of FS#12950 is implemented. On the backend side, I introduced a new function, alpm_db_set_pkgreason(), to modify the install reason of a package in the local database. On the front-end side, I introduced a new main operation, -D/--database, which has two options, --asdeps and --asexplicit. I documented this in pacman manual. I've created two pactests to test -D: database001.py and database002.py. Signed-off-by: Nagy Gabor <ngaba@bibl.u-szeged.hu> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 220ee9cb..8c14562c 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -24,6 +24,7 @@ endif
pacman_SOURCES = \
conf.h conf.c \
+ database.c \
deptest.c \
package.h package.c \
pacman.h pacman.c \