summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-08-22 03:53:38 +0200
committerDan McGee <dan@archlinux.org>2007-08-22 03:53:38 +0200
commitd09d114e99c29d1392c546a6553650ecde5138fc (patch)
tree0f0a66c93515860f644614faae52752f4b077029 /src/pacman/Makefile.am
parentc22e381a8b86412b6c181446128affe32ab1d71e (diff)
downloadpacman-d09d114e99c29d1392c546a6553650ecde5138fc.tar.gz
pacman-d09d114e99c29d1392c546a6553650ecde5138fc.tar.xz
Add a default cachedir if one wasn't specified
Use the default cachedir (specified at compile time) if one wasn't specified on the command line or in the config file. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index d997ecc6..939ff197 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -1,6 +1,7 @@
# paths set at make time
conffile = ${sysconfdir}/pacman.conf
dbpath = ${localstatedir}/lib/pacman/
+cachedir = ${localstatedir}/cache/pacman/pkg/
bin_PROGRAMS = pacman pacman.static
@@ -8,6 +9,7 @@ DEFS = -DLOCALEDIR=\"@localedir@\" \
-DCONFFILE=\"$(conffile)\" \
-DROOTDIR=\"$(ROOTDIR)\" \
-DDBPATH=\"$(dbpath)\" \
+ -DCACHEDIR=\"$(cachedir)\" \
@DEFS@
INCLUDES = -I$(top_srcdir)/lib/libalpm