summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-04-26 02:02:07 +0200
committerDan McGee <dan@archlinux.org>2007-04-26 20:34:41 +0200
commitdc05cd107cd158e3d8ee9256205aec20615a674f (patch)
treefec60599b46af26d51c0b08acd6afed2c0c0fc03 /src/pacman/Makefile.am
parent97313ba31645796148c3f413d9ebde365df06dbe (diff)
downloadpacman-dc05cd107cd158e3d8ee9256205aec20615a674f.tar.gz
pacman-dc05cd107cd158e3d8ee9256205aec20615a674f.tar.xz
Pacman side code consolidation- unify callback functions to one file
Some more major code reorginization here. The download progress callback function has been renamed and moved to callback.c, which is the former trans.c with the download and log callbacks added. In addition, this allows util.c to be cleaned up as fill_progress can now be static in callback.c. We've also cut two more source files out. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 21099657..241188ab 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -16,14 +16,13 @@ pacman_SOURCES = \
add.c \
conf.h conf.c \
deptest.c \
- downloadprog.h downloadprog.c \
log.h log.c \
package.h package.c \
pacman.h pacman.c \
query.c \
remove.c \
sync.c \
- trans.h trans.c \
+ callback.h callback.c \
util.h util.c
pacman_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la \