summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-11-02 01:36:50 +0100
committerDan McGee <dan@archlinux.org>2007-11-04 17:42:08 +0100
commite5be26fb233e0d29148846db21a70870ebe0d0bb (patch)
treee63fb7337ead4a87fc975eff04fa843ca6ed5033 /src/pacman/Makefile.am
parentc26fe63ee5d84492bcfb36664af8a90619e6ded5 (diff)
downloadpacman-e5be26fb233e0d29148846db21a70870ebe0d0bb.tar.gz
pacman-e5be26fb233e0d29148846db21a70870ebe0d0bb.tar.xz
Make building of pacman.static optional
Because building of pacman.static fails on some platforms, we should make it optional. It is enabled by default but can be disabled with the use of the --disable-pacman-static flag. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 4fe8b4fd..d0b727f6 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -3,7 +3,11 @@ conffile = ${sysconfdir}/pacman.conf
dbpath = ${localstatedir}/lib/pacman/
cachedir = ${localstatedir}/cache/pacman/pkg/
-bin_PROGRAMS = pacman pacman.static
+bin_PROGRAMS = pacman
+
+if INCLUDE_PACMAN_STATIC
+bin_PROGRAMS += pacman.static
+endif
DEFS = -DLOCALEDIR=\"@localedir@\" \
-DCONFFILE=\"$(conffile)\" \