summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2011-08-06 03:20:20 +0200
committerDan McGee <dan@archlinux.org>2011-08-08 23:49:43 +0200
commit0b57da2a43128dfaf475038eef938cae9cc24de1 (patch)
tree1f09ece24c00dfac5856a5394b8010531c8917de /src/util/Makefile.am
parentfab66f157d1b622cb120e21373a4893ad693ff33 (diff)
downloadpacman-0b57da2a43128dfaf475038eef938cae9cc24de1.tar.gz
pacman-0b57da2a43128dfaf475038eef938cae9cc24de1.tar.xz
pacsort: add new utility
pacsort is a command line sorting utility that implements libalpm's alpm_pkg_vercmp algorithm. Signed-off-by: Dave Reisner <dreisner@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 30a2ee35..f2774657 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -3,7 +3,7 @@ conffile = ${sysconfdir}/pacman.conf
dbpath = ${localstatedir}/lib/pacman/
cachedir = ${localstatedir}/cache/pacman/pkg/
-bin_PROGRAMS = vercmp testpkg testdb cleanupdelta pactree
+bin_PROGRAMS = vercmp testpkg testdb cleanupdelta pacsort pactree
DEFS = -DLOCALEDIR=\"@localedir@\" \
-DCONFFILE=\"$(conffile)\" \
@@ -27,8 +27,10 @@ testdb_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
cleanupdelta_SOURCES = cleanupdelta.c
cleanupdelta_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
+pacsort_SOURCES = pacsort.c
+pacsort_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
+
pactree_SOURCES = pactree.c
pactree_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
-
# vim:set ts=2 sw=2 noet: