summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 96d8f167..4feb9dd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,7 +174,7 @@ AC_FUNC_STRFTIME
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([getcwd gettimeofday memmove memset mkdir realpath regcomp \
rmdir setenv setlocale sqrt strcasecmp strchr strdup strerror \
- strndup strrchr strsep strstr strverscmp uname mtrace geteuid])
+ strndup strrchr strsep strstr strverscmp uname geteuid])
# Enable large file support if available
AC_SYS_LARGEFILE
@@ -267,20 +267,22 @@ AM_CONDITIONAL(USE_ASCIIDOC, test "x$useasciidoc" = "xyes")
# Enable or disable debug code
AC_MSG_CHECKING(for debug mode request)
if test "x$debug" = "xyes" ; then
+ AC_MSG_RESULT(yes)
AC_DEFINE([PACMAN_DEBUG], , [Enable debug code])
+ # Check for mcheck
+ AC_CHECK_HEADERS([mcheck.h])
+
CFLAGS="$CFLAGS -g -Wall -Werror -fstack-protector-all -std=c99"
- LDFLAGS="$LDFLAGS -lmcheck"
- AC_MSG_RESULT(yes)
else
- CFLAGS="$CFLAGS -Wall -std=c99"
AC_MSG_RESULT(no)
+ CFLAGS="$CFLAGS -Wall -std=c99"
fi
# Enable or disable inclusion of abs script
AC_MSG_CHECKING(for inclusion of abs script)
if test "x$includeabs" = "xyes" ; then
- AC_DEFINE([INCLUDE_ABS], , [Include abs script])
AC_MSG_RESULT(yes)
+ AC_DEFINE([INCLUDE_ABS], , [Include abs script])
else
AC_MSG_RESULT(no)
fi