summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c695c57f..eabb4a4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,13 +172,20 @@ GCC_VISIBILITY_CC
# Check if we have -fgnu89-inline flag
GCC_GNU89_INLINE_CC
-# Host-dependant flags
-case "${host}" in
- *-*-cygwin*)
+# Host-dependant definitions
+case "${host_os}" in
+ cygwin*)
+ host_os_cygwin=yes
CFLAGS="$CFLAGS -DCYGWIN"
;;
+ darwin*)
+ host_os_darwin=yes
+ ;;
esac
+AM_CONDITIONAL([CYGWIN], test "x$host_os_cygwin" = "xyes")
+AM_CONDITIONAL([DARWIN], test "x$host_os_darwin" = "xyes")
+
# Check for architecture, used in default makepkg.conf
# (Note single space left after CARCHFLAGS)
case "${host}" in