summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 17 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 359d045c..05c8ea11 100644
--- a/configure.in
+++ b/configure.in
@@ -1,35 +1,46 @@
+# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.57)
AC_INIT(FULL-PACKAGE-NAME, VERSION, BUG-REPORT-ADDRESS)
-AC_CONFIG_SRCDIR([acconfig.h])
+AC_CONFIG_SRCDIR([config.h.in])
AC_CONFIG_HEADER([config.h])
# Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
AC_PROG_CXX
# Checks for libraries.
-# AC_CHECK_LIB([tar], [tar_open])
-AC_CHECK_LIB([z], [gzread])
+AC_CHECK_LIB([c], [printf], , AC_MSG_ERROR([your libc is broken!]))
+AC_CHECK_LIB([tar], [tar_open], , AC_MSG_ERROR([missing libtar]))
+AC_CHECK_LIB([z], [gzread], , AC_MSG_ERROR([missing zlib]))
# Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
-AC_CHECK_HEADERS([fcntl.h limits.h stdlib.h string.h unistd.h])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/time.h unistd.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_MODE_T
AC_TYPE_SIZE_T
+AC_HEADER_TIME
+AC_TYPE_UID_T
# Checks for library functions.
-AC_FUNC_ALLOCA
+AC_FUNC_CLOSEDIR_VOID
AC_FUNC_LSTAT
+AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_FUNC_SELECT_ARGTYPES
AC_TYPE_SIGNAL
AC_FUNC_STAT
AC_FUNC_VPRINTF
-AC_CHECK_FUNCS([getpass memmove mkdir realpath rmdir strdup strerror strstr strverscmp])
+AC_CHECK_FUNCS([gethostbyname memmove memset mkdir realpath rmdir select socket strcasecmp strchr strdup strerror strstr strverscmp])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT