summaryrefslogtreecommitdiffstats
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am33
1 files changed, 31 insertions, 2 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index c6243b16..dd0b767c 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,4 +1,4 @@
-EXTRA_DIST = \
+OURFILES = \
PKGBUILD.vim \
bacman \
bash_completion \
@@ -9,7 +9,36 @@ EXTRA_DIST = \
pactree \
vimprojects \
wget-xdelta.sh \
- zsh_completion \
+ zsh_completion
+
+EXTRA_DIST = \
+ PKGBUILD.vim.in \
+ bacman.in \
+ bash_completion.in \
+ pacdiff.in \
+ paclist.in \
+ pacscripts.in \
+ pacsearch.in \
+ pactree.in \
+ vimprojects.in \
+ wget-xdelta.sh.in \
+ zsh_completion.in \
README
+# Files that should be removed, but which Automake does not know.
+MOSTLYCLEANFILES = $(OURFILES) *.tmp
+
+edit = sed \
+ -e 's|@sysconfdir[@]|$(sysconfdir)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g' \
+ -e 's|@BASH[@]|$(BASH)|g'
+
+$(OURFILES): Makefile
+ @rm -f $@ $@.tmp
+ @cp -a $@.in $@.tmp
+ $(edit) $@.in >$@.tmp
+ @mv $@.tmp $@
+
+all-am: $(OURFILES)
+
# vim:set ts=2 sw=2 noet: