summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index d5b7aada..ad677391 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -66,12 +66,6 @@ else
REAL_PACKAGE_VERSION = $(PACKAGE_VERSION)
endif
-#### Taken from the autoconf scripts Makefile.am ####
-edit = sed \
- -e 's|@STRIP_BINARIES[@]|$(STRIP_BINARIES)|g' \
- -e 's|@STRIP_SHARED[@]|$(STRIP_SHARED)|g' \
- -e 's|@STRIP_STATIC[@]|$(STRIP_STATIC)|g'
-
man_MANS =
dist_man_MANS = $(ASCIIDOC_MANS) repo-remove.8
@@ -102,11 +96,8 @@ A2X_OPTS = \
--xsltproc-opts='-param man.endnotes.list.enabled 0 -param man.endnotes.are.numbered 0'
# These rules are due to the includes and files of the asciidoc text
-$(ASCIIDOC_MANS): asciidoc.conf footer.txt Makefile
- @echo GEN $@;
- @test -f $(srcdir)/$@.txt && $(edit) $(srcdir)/$@.txt >$@.tmp || true
- a2x $(A2X_OPTS) --asciidoc-opts="$(ASCIIDOC_OPTS)" $@.tmp
- @rm -f $@.tmp
+$(ASCIIDOC_MANS): asciidoc.conf footer.txt
+ a2x $(A2X_OPTS) --asciidoc-opts="$(ASCIIDOC_OPTS)" $@.txt
%.html: %.txt
asciidoc $(ASCIIDOC_OPTS) -a linkcss $*.txt