summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am48
1 files changed, 24 insertions, 24 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index df55026a..ead359c3 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,27 +1,3 @@
-all: makepkg.8 pacman.8 PKGBUILD.5 makepkg.conf.5 pacman.conf.5
-
-if HAS_MAN2HTML
-makepkg.8:
- man2html makepkg.8 > html/makepkg.8.html
-
-pacman.8:
- man2html pacman.8 > html/pacman.8.html
-
-PKGBUILD.5:
- man2html PKGBUILD.5 > html/PKGBUILD.5.html
-
-makepkg.conf.5:
- man2html makepkg.8 > html/makepkg.8.html
-
-pacman.conf.5:
- man2html pacman.conf.5 > html/pacman.conf.5.html
-
-endif
-
-clean:
- rm -f html/*.html
- rm -f man3/*.3
-
man_MANS = \
pacman.8 \
makepkg.8 \
@@ -35,3 +11,27 @@ man_MANS += $(wildcard man3/*.3)
endif
EXTRA_DIST = $(man_MANS)
+
+MAN2HTML=man2html -r
+SUFFIXES=.3 .5 .8 .3.html .5.html .8.html
+
+# targets for each man section, sed removes a weird artifact left by man2html
+.3.3.html:
+ $(RM) $@
+ -${MAN2HTML} $< | sed '1,2d' > $@
+
+.5.5.html:
+ $(RM) $@
+ -${MAN2HTML} $< | sed '1,2d' > $@
+
+.8.8.html:
+ $(RM) $@
+ -${MAN2HTML} $< | sed '1,2d' > $@
+
+man2html: pacman.8.html makepkg.8.html PKGBUILD.5.html makepkg.conf.5.html pacman.conf.5.html libalpm.3.html
+
+clean-local:
+ $(RM) *.html
+ $(RM) man3/*.3
+
+.PHONY: man2html