summaryrefslogtreecommitdiffstats
path: root/doc/PKGBUILD.8
diff options
context:
space:
mode:
Diffstat (limited to 'doc/PKGBUILD.8')
-rw-r--r--doc/PKGBUILD.844
1 files changed, 22 insertions, 22 deletions
diff --git a/doc/PKGBUILD.8 b/doc/PKGBUILD.8
index 61fc7208..024543cb 100644
--- a/doc/PKGBUILD.8
+++ b/doc/PKGBUILD.8
@@ -1,14 +1,14 @@
-.TH FrugalBuild 8 "June 13, 2006" "Frugalware Developer Manual" ""
+.TH PKGBUILD 8 "June 13, 2006" "Archlinux Developer Manual" ""
.SH NAME
-FrugalBuild \- Frugalware package builder descriptor
+PKGBUILD \- Archlinux package builder descriptor
.SH DESCRIPTION
-This manual page is meant to describe general rules about FrugalBuilds. If
+This manual page is meant to describe general rules about PKGBUILDs. If
you're interested in the package builder \fBmakepkg\fP itself, then see its
manual page, not this one.
.TP
.TP
-.SH FrugalBuild Example:
+.SH PKGBUILD Example:
.RS
.nf
# Last Modified: Sun, 19 Jun 2005 15:24:32 +0000
@@ -47,13 +47,13 @@ successful builds, and this SBU value will be equal on anyone's machine.
If you wish to maintain the package, write your name or nick and e-mail
address to the third line. If you don't plan to maintain the package just wrote
-the FrugalBuild, then write Contributor instead of Maintainer, and then someone
+the PKGBUILD, then write Contributor instead of Maintainer, and then someone
can take it and will add his/her line later. Other lines like "Modified by" are
not allowed. Use the darcs patch comments to mention others if you wish.
pkgname defines the package name. It should not contain any uppercase letters.
The package version defines the upstream version, while the package release
-tracks the Frugalware-specific changes. pkgrel should be an integer, pkgrels
+tracks the Archlinux-specific changes. pkgrel should be an integer, pkgrels
like 5wanda1 are reserved for security updates. There the rule is the
following: If the original package's pkgrel was 4, then increment it once when
you add a security patch, but then use 5wanda1, 5wanda2 and so on. This way
@@ -68,9 +68,9 @@ current one. If the dependency is runtime-only, then use rodepends(), if
buildtime-only then use makedepends().
The next line is a special Finclude commands which allows you to inherit
-any directive from a FrugalBuild scheme. They can be found in the FST,
+any directive from a PKGBUILD scheme. They can be found in the FST,
under /source/include. The "util" scheme always included, since its
-provided functions are used by almost every FrugalBuild. Look at the
+provided functions are used by almost every PKGBUILD. Look at the
/source/include/sourceforge.sh, it provides the url, up2date and source()
directives, so we don't have to specify them here. After the Finclude you
can overwrite the inherited directives, for example define a custom up2date
@@ -93,7 +93,7 @@ is to prevent compiling from wrong sources, especially when the build is
automatic. Where it is available you can use signatures(), its goal is that
you don't have to update it manually every time.
-The last line will be added automatically to the end of the FrugalBuild if the
+The last line will be added automatically to the end of the PKGBUILD if the
build() function used your $CFLAGS or $CXXFLAGS. This is handy if you want to
cross-compile on a faster machine for a slower architecture. Until the package
doesn't use our $CFLAGS we can't cross-compile it, so please try to avoid
@@ -150,7 +150,7 @@ script is run right after files are removed.
.RE
To use this feature, just create a file (eg, pkgname.install) and put it in
-the same directory as the FrugalBuild script. Then use the \fIinstall\fP directive:
+the same directory as the PKGBUILD script. Then use the \fIinstall\fP directive:
.RS
.nf
install=pkgname.install
@@ -176,7 +176,7 @@ post_upgrade()
}
.fi
-.SH FrugalBuild Directives
+.SH PKGBUILD Directives
.TP
.B pkgname
The name of the package. This has be a unix-friendly name as it will be
@@ -188,7 +188,7 @@ This is the version of the software as released from the author (eg, 2.7.1).
.TP
.B pkgrel
-This is the release number specific to Frugalware Linux packages.
+This is the release number specific to Archlinux Linux packages.
.TP
.B pkgdesc
@@ -214,7 +214,7 @@ option is still in development and may change in the future)
.TP
.B install
Specifies a special install script that is to be included in the package.
-This file should reside in the same directory as the FrugalBuild, and will be
+This file should reside in the same directory as the PKGBUILD, and will be
copied into the package by makepkg. It does not need to be included in the
\fIsource\fP array. (eg, install=modutils.install)
@@ -227,7 +227,7 @@ manually the project's website (see above).
.TP
.B source \fI(array)\fP
The \fIsource\fP line is an array of source files required to build the
-package. Source files must reside in the same directory as the FrugalBuild
+package. Source files must reside in the same directory as the PKGBUILD
file, unless they have a fully-qualified URL. Then if the source file
does not already exist in /var/cache/pacman/src, the file is downloaded
by wget.
@@ -237,8 +237,8 @@ by wget.
If this field is present, it should contain an MD5 hash for every source file
specified in the \fIsource\fP array (in the same order). makepkg will use
this to verify source file integrity during subsequent builds. To easily
-generate md5sums, first build using the FrugalBuild then run
-\fBmakepkg -G >>FrugalBuild\fP. Then you can edit the FrugalBuild and move the
+generate md5sums, first build using the PKGBUILD then run
+\fBmakepkg -G >>PKGBUILD\fP. Then you can edit the PKGBUILD and move the
\fImd5sums\fP line from the bottom to an appropriate location.
.TP
@@ -246,8 +246,8 @@ generate md5sums, first build using the FrugalBuild then run
If this field is present, it should contain an SHA1 hash for every source file
specified in the \fIsource\fP array (in the same order). makepkg will use
this to verify source file integrity during subsequent builds. To easily
-generate sha1sums, first build using the FrugalBuild then run
-\fBmakepkg -g >>FrugalBuild\fP. Then you can edit the FrugalBuild and move the
+generate sha1sums, first build using the PKGBUILD then run
+\fBmakepkg -g >>PKGBUILD\fP. Then you can edit the PKGBUILD and move the
\fIsha1sums\fP line from the bottom to an appropriate location.
.TP
@@ -285,7 +285,7 @@ in this list should be surrounded with single quotes and contain at least the
package name. They can also include a version requirement of the form
\fBname<>version\fP, where <> is one of these three comparisons: \fB>=\fP
(greater than equal to), \fB<=\fP (less than or equal to), or \fB=\fP (equal to).
-See the FrugalBuild example above for an example of the \fIdepends\fP directive.
+See the PKGBUILD example above for an example of the \fIdepends\fP directive.
.TP
.B makedepends \fI(array)\fP
@@ -365,7 +365,7 @@ devel-core' should show you the actial list. (We try to change this list rarely
of course.)
When you start building with makepkg -R, pacman will install these packages to
-/var/chroot if necessary. This will produce a fully "clean" Frugalware system,
+/var/chroot if necessary. This will produce a fully "clean" Archlinux system,
that consits of base packages only. This /var/chroot is fully separated from
the host system so that this will solve the problems mentioned above.
(Linking to a library installed from source, etc.)
@@ -380,7 +380,7 @@ installed depends() and makedepends(). This ensures us not to build from
scratch the core chroot.
This way we can prevent lots of dependency problems and it is even possible to
-build packages for a different Frugalware version. This is quite efficent when
+build packages for a different Archlinux version. This is quite efficent when
building security updates or fixing critical bugs in the -stable tree.
If the build is failed, the working directory will not be deleted, you can find
@@ -425,7 +425,7 @@ array of arrays, then quotes are the major separators and spaces are the minor o
Simple example:
.nf
-Add the followings to your bottom of your FrugalBuild
+Add the followings to your bottom of your PKGBUILD
subpkgs=('foo' 'bar')
subdescs=('desc of foo' 'desc of bar')
subdepends=('foodep1 foodep2' 'bardep1 bardep2')