summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index c8ce9773..d296d485 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -9,23 +9,21 @@ logfile = ${localstatedir}/log/pacman.log
bin_PROGRAMS = pacman
-DEFS = -DLOCALEDIR=\"@localedir@\" \
- -DCONFFILE=\"$(conffile)\" \
- -DDBPATH=\"$(dbpath)\" \
- -DGPGDIR=\"$(gpgdir)\" \
- -DCACHEDIR=\"$(cachedir)\" \
- -DLOGFILE=\"$(logfile)\" \
- @DEFS@
-
AM_CPPFLAGS = \
-imacros $(top_builddir)/config.h \
- -I$(top_srcdir)/lib/libalpm
+ -I$(top_srcdir)/lib/libalpm \
+ -DLOCALEDIR=\"@localedir@\" \
+ -DCONFFILE=\"$(conffile)\" \
+ -DDBPATH=\"$(dbpath)\" \
+ -DGPGDIR=\"$(gpgdir)\" \
+ -DCACHEDIR=\"$(cachedir)\" \
+ -DLOGFILE=\"$(logfile)\"
AM_CFLAGS = -pedantic -D_GNU_SOURCE $(WARNING_CFLAGS)
if USE_GIT_VERSION
GIT_VERSION := $(shell sh -c 'git describe --abbrev=4 --dirty | sed s/^v//')
-DEFS += -DGIT_VERSION=\"$(GIT_VERSION)\"
+AM_CPPFLAGS += -DGIT_VERSION=\"$(GIT_VERSION)\"
endif
pacman_SOURCES = \