summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 463abf7f..d539fa26 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -6,16 +6,14 @@ cachedir = ${localstatedir}/cache/pacman/pkg/
bin_PROGRAMS = vercmp testpkg testdb cleanupdelta pacsort pactree
-DEFS = -DLOCALEDIR=\"@localedir@\" \
- -DCONFFILE=\"$(conffile)\" \
- -DDBPATH=\"$(dbpath)\" \
- -DGPGDIR=\"$(gpgdir)\" \
- -DCACHEDIR=\"$(cachedir)\" \
- @DEFS@
-
AM_CPPFLAGS = \
-imacros $(top_builddir)/config.h \
- -I$(top_srcdir)/lib/libalpm
+ -I$(top_srcdir)/lib/libalpm \
+ -DLOCALEDIR=\"@localedir@\" \
+ -DCONFFILE=\"$(conffile)\" \
+ -DDBPATH=\"$(dbpath)\" \
+ -DGPGDIR=\"$(gpgdir)\" \
+ -DCACHEDIR=\"$(cachedir)\"
AM_CFLAGS = -pedantic -D_GNU_SOURCE $(WARNING_CFLAGS)