summaryrefslogtreecommitdiffstats
path: root/test/pacman/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/pacman/meson.build')
-rw-r--r--test/pacman/meson.build15
1 files changed, 14 insertions, 1 deletions
diff --git a/test/pacman/meson.build b/test/pacman/meson.build
index 9de4f5a1..fd0dbf90 100644
--- a/test/pacman/meson.build
+++ b/test/pacman/meson.build
@@ -330,6 +330,17 @@ pacman_tests = [
'tests/xfercommand001.py',
]
+xfail_tests = {
+ 'tests/deprange001.py': true,
+ # expect failure on 32 bit machines
+ 'tests/query006.py': cc.sizeof('ssize_t') < 8,
+ 'tests/replace110.py': true,
+ 'tests/sync-update-package-removing-required-provides.py': true,
+ 'tests/sync403.py': true,
+ 'tests/sync406.py': true,
+ 'tests/upgrade078.py': true,
+}
+
foreach input : pacman_tests
test_name = input.split('/')[1]
args = [
@@ -351,7 +362,9 @@ foreach input : pacman_tests
test_name,
PYTHON,
protocol : 'tap',
+ env : ['RUNNING_UNDER_MESON=1'],
args : args,
- timeout: 120,
+ timeout : 120,
+ should_fail : xfail_tests.get(input, false),
depends : [pacman_bin])
endforeach