summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTobi Oetiker <tobi@oetiker.ch>2011-09-28 23:17:26 +0200
committerTobi Oetiker <tobi@oetiker.ch>2011-09-28 23:17:26 +0200
commit4b3cafae64c7c562cbec2231488f63d912f269ca (patch)
tree5d9a5e9415dbb1720a5ab6766d59317c771a556d /Makefile.am
parent039861d743c2993959aca1a3e52045e8f6073d0a (diff)
downloadsmokeping-4b3cafae64c7c562cbec2231488f63d912f269ca.tar.gz
smokeping-4b3cafae64c7c562cbec2231488f63d912f269ca.tar.xz
added automake support
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..86927a3
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,29 @@
+# Copyright (C) 2011 Tobias Oetiker
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = bin doc etc htdocs lib
+
+EXTRA_DIST = setup/build-perl-modules.sh setup/sdbs.inc
+
+dist-hook:
+ svn info >DIST_REVISION
+ cp DIST_REVISION $(distdir)/
+
+# date >DIST_REVISION
+# git branch -vv >>DIST_REVISION
+