summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTobi Oetiker <tobi@oetiker.ch>2011-09-28 23:17:26 +0200
committerTobi Oetiker <tobi@oetiker.ch>2011-09-28 23:17:26 +0200
commit4b3cafae64c7c562cbec2231488f63d912f269ca (patch)
tree5d9a5e9415dbb1720a5ab6766d59317c771a556d /configure.ac
parent039861d743c2993959aca1a3e52045e8f6073d0a (diff)
downloadsmokeping-4b3cafae64c7c562cbec2231488f63d912f269ca.tar.gz
smokeping-4b3cafae64c7c562cbec2231488f63d912f269ca.tar.xz
added automake support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac81
1 files changed, 81 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..888da27
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,81 @@
+# Copyright (C) 2011 Tobi Oetiker
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+
+#
+
+
+AC_INIT([smokeping],[2.5.2],[tobi@oetiker.ch])
+AC_PREREQ([2.59])
+AC_CONFIG_AUX_DIR(conftools)
+AC_CANONICAL_HOST
+AM_INIT_AUTOMAKE(1.9)
+AM_MAINTAINER_MODE
+
+AC_PREFIX_DEFAULT( /opt/smokeping-$PACKAGE_VERSION )
+
+AC_PATH_PROG(PERL, perl, no)
+AC_PATH_PROG(SED, sed, no)
+AC_PATH_PROG(GREP, grep, no)
+AC_PATH_PROG(ECHO, echo, no)
+AC_PATH_PROG(LN, ln, no)
+AC_PATH_PROG(CP, cp, no)
+AC_PATH_PROG(RM, rm, no)
+AC_PATH_PROG(RMDIR, rmdir, no)
+AC_PATH_PROG(MKDIR, mkdir, no)
+AC_PATH_PROG(FIND, find, no)
+
+
+AC_ARG_ENABLE(pkgonly,
+ [AC_HELP_STRING([--enable-pkgonly],
+ [Skip all checking])])
+AC_SUBST(enable_pkgonly)
+
+
+PERLLIBDIRS=
+
+PERLOPTS=
+AC_ARG_WITH(perl-inc,[ --with-perl-inc=[DIRS] Additional space-separated Perl library paths], [PERLINC=$withval])
+AC_ARG_VAR(PERLINC, [[] Additional space-separated Perl library paths])
+if test ! -z "$PERLINC"; then
+ for d in $PERLINC; do
+ PERLOPTS="${PERLOPTS} -I${d}"
+ perllibdirs=${perllibdirs}"\,\'"${d}"\'"
+ done
+fi
+AC_SUBST(PERLOPTS)
+
+AC_SUBST(PERLLIBDIRS, [${perllibdirs}])
+
+
+# Check the necessary Perl modules
+
+if test "$enable_pkgonly" != yes; then
+ for module in RRDs FCGI CGI CGI::Fast Config::Grammar Digest::HMAC_MD5; do
+ AC_MSG_CHECKING([presence of $module])
+ if ${PERL} ${PERLOPTS} -e 'use '$module; then
+ AC_MSG_RESULT([Ok])
+ else
+ AC_MSG_ERROR([Perl cannot find $module ($PERLOPTS)]);
+ fi
+ done
+fi
+
+
+AC_CONFIG_FILES([Makefile bin/Makefile doc/Makefile htdocs/Makefile etc/Makefile lib/Makefile])
+
+AC_SUBST(VERSION)
+
+AC_OUTPUT