summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Wilde <github@krellis.org>2011-10-30 02:54:08 +0200
committerTim Wilde <github@krellis.org>2011-10-30 02:54:08 +0200
commita40ae75d8c76fe578f54cd5afd879de4ae0b744f (patch)
tree8d8e77a9c334b7756fbd04a3741d54617507930e /configure.ac
parent677f0b4d837b4b040d085aedce6f09120a912cdf (diff)
downloadsmokeping-a40ae75d8c76fe578f54cd5afd879de4ae0b744f.tar.gz
smokeping-a40ae75d8c76fe578f54cd5afd879de4ae0b744f.tar.xz
Automatically configure etc/config.dist paths
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 2ff9ff3..d1e2efc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,7 @@ AC_PATH_PROG(RM, rm, no)
AC_PATH_PROG(RMDIR, rmdir, no)
AC_PATH_PROG(MKDIR, mkdir, no)
AC_PATH_PROG(FIND, find, no)
+AC_PATH_PROG(SENDMAIL, sendmail, /path/to/sendmail, [$PATH$PATH_SEPARATOR/usr/sbin$PATH_SEPARATOR/usr/lib])
AC_PATH_PROGS(NROFF, [gnroff nroff])
AC_ARG_VAR(GMAKE, [Path to local GNU Make binary])
@@ -80,13 +81,9 @@ AC_SUBST(PERL5LIB)
mod_ok=1
if test "$enable_pkgonly" != yes; then
- prfx=$prefix
- if test x$prfx = xNONE; then
- prfx=$ac_default_prefix
- fi
for module in RRDs FCGI CGI CGI::Fast Config::Grammar Digest::HMAC_MD5 LWP; do
AC_MSG_CHECKING([checking for perl module '$module'])
- if ${PERL} -I$prfx/thirdparty/lib/perl5 -e 'use '$module 2>/dev/null ; then
+ if ${PERL} -I$prefix/thirdparty/lib/perl5 -e 'use '$module 2>/dev/null ; then
AC_MSG_RESULT([Ok])
else
AC_MSG_RESULT([Failed])
@@ -107,7 +104,7 @@ if test "$enable_pkgonly" != yes; then
Now you can install local copies of the missing modules
by running
- ./setup/build-perl-modules.sh ${prfx}/thirdparty
+ ./setup/build-perl-modules.sh ${prefix}/thirdparty
The RRDs perl module is part of RRDtool. Either use the rrdtool
package provided by your OS or install rrdtool from source.
@@ -121,7 +118,7 @@ NOTES
fi
-AC_CONFIG_FILES([Makefile bin/Makefile doc/Makefile htdocs/Makefile etc/Makefile lib/Makefile])
+AC_CONFIG_FILES([Makefile bin/Makefile doc/Makefile htdocs/Makefile etc/Makefile lib/Makefile etc/config.dist])
AC_SUBST(VERSION)