summaryrefslogtreecommitdiffstats
path: root/bin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index 81a47df..01030c8 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -16,3 +16,8 @@
dist_bin_SCRIPTS = smokeinfo smokeping smokeping_cgi tSmoke
+
+install-exec-hook:
+ [ x$PERL5LIB != x ] && cd "$(bindir)" && $(PERL) -i -p -e 's{^#!.*}{#!$(PERL)}; s{.*# PERL5LIB}{use lib qw($(PERL5LIB)); # PERL5LIB}' smokeinfo smokeping smokeping_cgi tSmoke
+
+# EOF