summaryrefslogtreecommitdiffstats
path: root/htdocs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'htdocs/Makefile.am')
-rw-r--r--htdocs/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/htdocs/Makefile.am b/htdocs/Makefile.am
index 11b69e7..d8c592c 100644
--- a/htdocs/Makefile.am
+++ b/htdocs/Makefile.am
@@ -27,5 +27,8 @@ EXTRA_DIST = $(JS) $(CGI)
jsdir = $(DESTDIR)$(HTDOCSDIR)
nobase_js_DATA = $(JS)
-js_SCRIPTS = $(CGI)
+install-data-local:
+ $(ECHO) "#!/bin/sh" > $(DESTDIR)$(HTDOCSDIR)/smokeping.fcgi.dist
+ $(ECHO) "$(prefix)/bin/smokeping_cgi $(prefix)/etc/config" >> $(DESTDIR)$(HTDOCSDIR)/smokeping.fcgi.dist
+ chmod +x $(DESTDIR)$(HTDOCSDIR)/smokeping.fcgi.dist