summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-26 18:02:59 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-26 18:03:07 +0100
commit1db94feb0c1ea3d1b4cb69c044a9379c8f0f847d (patch)
tree35938e2ceb6b55e4cf544abfe59420be2753af5c
parent796f87cf34f485d18ef3b055615a1381df17d841 (diff)
downloadaur-packages-1db94feb0c1ea3d1b4cb69c044a9379c8f0f847d.tar.gz
aur-packages-1db94feb0c1ea3d1b4cb69c044a9379c8f0f847d.tar.xz
updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--blazeblogger-git/PKGBUILD2
-rw-r--r--dovecot-sieve/PKGBUILD4
-rw-r--r--php/PKGBUILD28
-rw-r--r--php/db-configure.patch6
-rw-r--r--php/php.ini.patch22
5 files changed, 34 insertions, 28 deletions
diff --git a/blazeblogger-git/PKGBUILD b/blazeblogger-git/PKGBUILD
index a3e29be..c7d0b0a 100644
--- a/blazeblogger-git/PKGBUILD
+++ b/blazeblogger-git/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Florian Pritz <bluewind@xssn.at>
# Contributor: Abakus <java5@arcor.de>
pkgname=blazeblogger-git
-pkgver=20090830
+pkgver=20091119
pkgrel=1
pkgdesc="is a simple-to-use but capable CMS for the command line"
arch=('any')
diff --git a/dovecot-sieve/PKGBUILD b/dovecot-sieve/PKGBUILD
index 08cc6e6..3d9e0ec 100644
--- a/dovecot-sieve/PKGBUILD
+++ b/dovecot-sieve/PKGBUILD
@@ -1,6 +1,6 @@
# Contributor: Paul Ezvan <paul@ezvan.fr>
pkgname=dovecot-sieve
-pkgver=0.1.12
+pkgver=0.1.13
pkgrel=1
_dovecotvers=1.2
pkgdesc="Dovecot sieve plugin"
@@ -9,7 +9,7 @@ url="http://wiki.dovecot.org/LDA/Sieve"
license=('LGPL')
depends=("dovecot>=$_dovecotvers")
source=(http://www.rename-it.nl/dovecot/$_dovecotvers/dovecot-$_dovecotvers-sieve-$pkgver.tar.gz)
-md5sums=('8749f26606c4563f0676bacc44e89ca2')
+md5sums=('6151ab50e24abc0384358b1618c8048f')
build() {
diff --git a/php/PKGBUILD b/php/PKGBUILD
index 79806a9..33fe6e7 100644
--- a/php/PKGBUILD
+++ b/php/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id$
+# $Id: PKGBUILD 59035 2009-11-19 16:11:32Z pierre $
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgbase=php
@@ -20,9 +20,9 @@ pkgname=('php'
'php-sqlite'
'php-tidy'
'php-xsl')
-pkgver=5.3.0
-pkgrel=3
-_suhosinver=${pkgver}-0.9.8-BETA-1
+pkgver=5.3.1
+pkgrel=1
+_suhosinver=${pkgver}RC1-0.9.8
arch=('i686' 'x86_64')
license=('PHP')
url='http://www.php.net'
@@ -33,13 +33,13 @@ makedepends=('apache' 'imap' 'postgresql-libs' 'mysql' 'libldap' 'postfix'
options=('!makeflags')
source=("http://www.php.net/distributions/${pkgbase}-${pkgver}.tar.bz2"
"http://download.suhosin.org/suhosin-patch-${_suhosinver}.patch.gz"
- 'php.ini.patch' 'apache.conf' 'db-configure.patch' 'gd-info-segfault.patch')
-md5sums=('846760cd655c98dfd86d6d97c3d964b0'
- '62dc36545b86bf86e44ada1fccc17d0a'
- '67c63d2c8a976a333bbd2216cdd60413'
+ 'php.ini.patch' 'apache.conf' 'db-configure.patch' 'mysqlnd-socket.patch')
+md5sums=('63e97ad450f0f7259e785100b634c797'
+ 'c3ff0cb5fa728420d56f8ed139446647'
+ 'd6f94150f47047882c6716575e12e99b'
'96ca078be6729b665be8a865535a97bf'
- '45ecb6fb0aadfd3462097e3bab951aa5'
- '1c1a50aae7207b12d27bdecd8967e7ce')
+ 'cd3d068931c3715e35634e9885e35374'
+ '993223e03e6c0cc2d89581550ebbbe67')
build() {
phpconfig="--prefix=/usr \
@@ -95,7 +95,7 @@ build() {
--with-jpeg-dir=shared,/usr \
--with-ldap=shared \
--with-mcrypt=shared \
- --with-mysql-sock=/tmp/mysql.sock \
+ --with-mysql-sock=/var/run/mysqld/mysqld.sock \
--with-mysql=shared,mysqlnd \
--with-mysqli=shared,mysqlnd \
--with-openssl=shared \
@@ -130,15 +130,15 @@ build() {
# avoid linking against old db version
patch -p0 -i ${srcdir}/db-configure.patch || return 1
+ # use /var/run/mysqld/mysqld.sock as default socket for mysql
+ patch -p0 -i ${srcdir}/mysqlnd-socket.patch || return 1
+
# apply suhosin patch
patch -p1 -i ${srcdir}/suhosin-patch-${_suhosinver}.patch || return 1
# adjust paths
patch -p0 -i ${srcdir}/php.ini.patch || return 1
- # fix gd segfault; http://bugs.php.net/bug.php?id=49193
- patch -p0 -i ${srcdir}/gd-info-segfault.patch || return 1
-
# php
mkdir ${srcdir}/build-php
cd ${srcdir}/build-php
diff --git a/php/db-configure.patch b/php/db-configure.patch
index 1d2c818..e09a39c 100644
--- a/php/db-configure.patch
+++ b/php/db-configure.patch
@@ -1,6 +1,6 @@
---- configure.orig 2009-06-29 17:46:18.000000000 +0200
-+++ configure 2009-08-14 08:34:52.000000000 +0200
-@@ -29088,43 +29088,15 @@
+--- configure 2009-11-18 21:11:57.000000000 +0100
++++ configure 2009-11-19 12:42:50.881918639 +0100
+@@ -29292,43 +29292,15 @@
unset THIS_INCLUDE THIS_LIBS THIS_LFLAGS THIS_PREFIX THIS_RESULT
diff --git a/php/php.ini.patch b/php/php.ini.patch
index cd91d50..9b1177b 100644
--- a/php/php.ini.patch
+++ b/php/php.ini.patch
@@ -1,5 +1,5 @@
---- php.ini-production 2009-06-30 01:05:38.000000000 +0200
-+++ php.ini 2009-06-30 01:02:15.000000000 +0200
+--- php.ini-production 2009-11-12 18:20:01.000000000 +0100
++++ php.ini 2009-11-19 12:39:03.305274757 +0100
@@ -376,7 +376,7 @@
; or per-virtualhost web server configuration file. This directive is
; *NOT* affected by whether Safe Mode is turned On or Off.
@@ -9,7 +9,7 @@
; This directive allows you to disable certain functions for security reasons.
; It receives a comma-delimited list of function names. This directive is
-@@ -785,7 +785,7 @@
+@@ -781,7 +781,7 @@
;;;;;;;;;;;;;;;;;;;;;;;;;
; UNIX: "/path1:/path2"
@@ -18,7 +18,7 @@
;
; Windows: "\path1;\path2"
;include_path = ".;c:\php\includes"
-@@ -808,7 +808,7 @@
+@@ -804,7 +804,7 @@
; Directory in which the loadable extensions (modules) reside.
; http://php.net/extension-dir
@@ -27,10 +27,16 @@
; On windows:
; extension_dir = "ext"
-@@ -945,47 +945,49 @@
- ; extension folders as well as the separate PECL DLL download (PHP 5).
- ; Be sure to appropriately set the extension_dir directive.
- ;
+@@ -938,53 +938,49 @@
+ ; If you only provide the name of the extension, PHP will look for it in its
+ ; default extension directory.
+ ;
+-; Windows Extensions
+-; Note that ODBC support is built in, so no dll is needed for it.
+-; Note that many DLL files are located in the extensions/ (PHP 4) ext/ (PHP 5)
+-; extension folders as well as the separate PECL DLL download (PHP 5).
+-; Be sure to appropriately set the extension_dir directive.
+-;
-;extension=php_bz2.dll
-;extension=php_curl.dll
-;extension=php_dba.dll