summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-26 18:01:56 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-26 18:03:07 +0100
commit796f87cf34f485d18ef3b055615a1381df17d841 (patch)
tree16509d783b743274f03ceb43e9ac24de18bf7ed1
parent2284cc46e1fa85d5a8fbfc80a0b052b2c07b9e5b (diff)
downloadaur-packages-796f87cf34f485d18ef3b055615a1381df17d841.tar.gz
aur-packages-796f87cf34f485d18ef3b055615a1381df17d841.tar.xz
add suphp
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--suphp/PKGBUILD25
-rw-r--r--suphp/suphp.conf47
2 files changed, 72 insertions, 0 deletions
diff --git a/suphp/PKGBUILD b/suphp/PKGBUILD
new file mode 100644
index 0000000..9216d74
--- /dev/null
+++ b/suphp/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: helios <helios@cyb0rg.org>
+pkgname=suphp
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="A tool for executing PHP scripts with the permissions of their owners."
+arch=("i686" "x86_64")
+depends=("apr-util" "apache")
+url="http://www.suphp.org/"
+license=('GPL')
+backup=('etc/suphp/suphp.conf')
+source=(http://www.suphp.org/download/$pkgname-$pkgver.tar.gz suphp.conf)
+md5sums=('c172dd4f15a75f4dcb08ea97d4202bb8' '797fb760d6a8ae833959f6b5cb64a2c1')
+
+build() {
+ cd "$startdir/src/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --with-apr=/usr/bin/apr-1-config --sysconfdir=/etc/suphp --with-apache-user=http --with-setid-mode=owner --with-min-uid=33 --with-min-gid=33
+ make || return 1
+ make DESTDIR="$startdir/pkg" install
+
+ install -D -m 644 ${startdir}/suphp.conf ${startdir}/pkg/etc/suphp/suphp.conf
+ install -D -m 644 ${startdir}/src/$pkgname-$pkgver/doc/suphp.conf-example ${startdir}/pkg/etc/suphp/suphp.conf.example
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/suphp/suphp.conf b/suphp/suphp.conf
new file mode 100644
index 0000000..a4c6cdf
--- /dev/null
+++ b/suphp/suphp.conf
@@ -0,0 +1,47 @@
+[global]
+;Path to logfile
+logfile=/var/log/suphp.log
+
+;Loglevel
+loglevel=info
+
+;User Apache is running as
+webserver_user=http
+
+;Path all scripts have to be in
+docroot=/var/www:${HOME}/public_html:/srv/http
+
+;Path to chroot() to before executing script
+;chroot=/mychroot
+
+; Security options
+allow_file_group_writeable=false
+allow_file_others_writeable=false
+allow_directory_group_writeable=false
+allow_directory_others_writeable=false
+
+;Check wheter script is within DOCUMENT_ROOT
+check_vhost_docroot=false
+
+;Send minor error messages to browser
+errors_to_browser=true
+
+;PATH environment variable
+env_path=/bin:/usr/bin
+
+;Umask to set, specify in octal notation
+umask=0077
+
+; Minimum UID
+min_uid=33
+
+; Minimum GID
+min_gid=33
+
+
+[handlers]
+;Handler for php-scripts
+x-httpd-php="php:/usr/bin/php-cgi"
+
+;Handler for CGI-scripts
+x-suphp-cgi="execute:!self"