summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2011-01-06 17:39:26 +0100
committerFlorian Pritz <bluewind@xssn.at>2011-01-06 17:39:33 +0100
commit4d3e14726681b63160f9e811134d980501cf9b67 (patch)
tree1bbd1ba48a99236784197f6008cb02f6258a3d0f
parentf291ddfd96f95c33250fe089d226376d78bc4996 (diff)
downloadaur-packages-4d3e14726681b63160f9e811134d980501cf9b67.tar.gz
aur-packages-4d3e14726681b63160f9e811134d980501cf9b67.tar.xz
thunar-notrash: update to 1.1.6
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--thunar-notrash/Ability_to_disable_trash_on_Thunar.patch170
-rw-r--r--thunar-notrash/Ability_to_disable_trash_on_Thunar_1.1.6.patch178
-rw-r--r--thunar-notrash/PKGBUILD51
-rw-r--r--thunar-notrash/libpng-1.4.patch12
4 files changed, 209 insertions, 202 deletions
diff --git a/thunar-notrash/Ability_to_disable_trash_on_Thunar.patch b/thunar-notrash/Ability_to_disable_trash_on_Thunar.patch
deleted file mode 100644
index 50e992e..0000000
--- a/thunar-notrash/Ability_to_disable_trash_on_Thunar.patch
+++ /dev/null
@@ -1,170 +0,0 @@
-diff -ur src/Thunar-1.0.1-orig/thunar/thunar-application.c src/Thunar-1.0.1/thunar/thunar-application.c
---- src/Thunar-1.0.1-orig/thunar/thunar-application.c 2009-01-12 21:38:48.000000000 +0100
-+++ src/Thunar-1.0.1/thunar/thunar-application.c 2009-06-21 02:07:38.000000000 +0200
-@@ -1328,13 +1328,20 @@
- gchar *message;
- guint n_path_list = 0;
- gint response;
-+ gboolean isTrashEnabled;
-
- _thunar_return_if_fail (parent == NULL || GDK_IS_SCREEN (parent) || GTK_IS_WIDGET (parent));
- _thunar_return_if_fail (THUNAR_IS_APPLICATION (application));
--
-+
- /* check if we should permanently delete the files (user holds shift) */
- permanently = (gtk_get_current_event_state (&state) && (state & GDK_SHIFT_MASK) != 0);
-
-+ g_object_get (G_OBJECT (application->preferences), "misc-enable-trash", &isTrashEnabled, NULL);
-+ if (!isTrashEnabled)
-+ {
-+ permanently = TRUE;
-+ }
-+
- /* determine the paths for the files */
- for (lp = g_list_last (file_list); lp != NULL; lp = lp->prev, ++n_path_list)
- {
-@@ -1354,8 +1361,8 @@
- if (G_UNLIKELY (permanently))
- {
- /* parse the parent pointer */
-- screen = thunar_util_parse_parent (parent, &window);
--
-+ screen = thunar_util_parse_parent (parent, &window);
-+
- /* generate the question to confirm the delete operation */
- if (G_LIKELY (n_path_list == 1))
- {
-diff -ur src/Thunar-1.0.1-orig/thunar/thunar-preferences-dialog.c src/Thunar-1.0.1/thunar/thunar-preferences-dialog.c
---- src/Thunar-1.0.1-orig/thunar/thunar-preferences-dialog.c 2009-01-12 21:38:48.000000000 +0100
-+++ src/Thunar-1.0.1/thunar/thunar-preferences-dialog.c 2009-06-21 02:19:11.000000000 +0200
-@@ -373,7 +373,7 @@
- gtk_frame_set_label_widget (GTK_FRAME (frame), label);
- gtk_widget_show (label);
-
-- table = gtk_table_new (2, 2, FALSE);
-+ table = gtk_table_new (3, 2, FALSE);
- gtk_table_set_row_spacings (GTK_TABLE (table), 6);
- gtk_table_set_col_spacings (GTK_TABLE (table), 12);
- gtk_container_set_border_width (GTK_CONTAINER (table), 12);
-@@ -418,7 +418,7 @@
- gtk_frame_set_label_widget (GTK_FRAME (frame), label);
- gtk_widget_show (label);
-
-- table = gtk_table_new (2, 2, FALSE);
-+ table = gtk_table_new (3, 2, FALSE);
- gtk_table_set_row_spacings (GTK_TABLE (table), 6);
- gtk_table_set_col_spacings (GTK_TABLE (table), 12);
- gtk_container_set_border_width (GTK_CONTAINER (table), 12);
-@@ -573,7 +573,7 @@
- gtk_frame_set_label_widget (GTK_FRAME (frame), label);
- gtk_widget_show (label);
-
-- table = gtk_table_new (2, 2, FALSE);
-+ table = gtk_table_new (3, 2, FALSE);
- gtk_table_set_row_spacings (GTK_TABLE (table), 6);
- gtk_table_set_col_spacings (GTK_TABLE (table), 12);
- gtk_container_set_border_width (GTK_CONTAINER (table), 12);
-@@ -591,6 +591,13 @@
- gtk_combo_box_append_text (GTK_COMBO_BOX (combo), _("Ask everytime"));
- gtk_combo_box_append_text (GTK_COMBO_BOX (combo), _("Apply to Folder Only"));
- gtk_combo_box_append_text (GTK_COMBO_BOX (combo), _("Apply to Folder and Contents"));
-+
-+ button = gtk_check_button_new_with_mnemonic (_("Move items to Trash when on _delete."));
-+ exo_mutual_binding_new (G_OBJECT (dialog->preferences), "misc-enable-trash", G_OBJECT (button), "active");
-+ thunar_gtk_widget_set_tooltip (button, _( "By default, items are sent to the Trash on delete. By disabling this option, items will be removed on delete and will be lost forever. (DANGEROUS)" ) );
-+ gtk_table_attach (GTK_TABLE (table), button, 0,1,2,3, GTK_EXPAND | GTK_FILL, GTK_FILL, 0, 0);
-+ gtk_widget_show (button);
-+
- #if !GTK_CHECK_VERSION(2,9,0)
- g_signal_connect (G_OBJECT (combo), "changed", G_CALLBACK (g_object_notify), "active");
- #endif
-@@ -608,7 +615,7 @@
- gtk_frame_set_label_widget (GTK_FRAME (frame), label);
- gtk_widget_show (label);
-
-- table = gtk_table_new (2, 2, FALSE);
-+ table = gtk_table_new (3, 2, FALSE);
- gtk_table_set_row_spacings (GTK_TABLE (table), 6);
- gtk_table_set_col_spacings (GTK_TABLE (table), 12);
- gtk_container_set_border_width (GTK_CONTAINER (table), 12);
-diff -ur src/Thunar-1.0.1-orig/thunar/thunar-preferences.c src/Thunar-1.0.1/thunar/thunar-preferences.c
---- src/Thunar-1.0.1-orig/thunar/thunar-preferences.c 2009-01-12 21:38:48.000000000 +0100
-+++ src/Thunar-1.0.1/thunar/thunar-preferences.c 2009-06-21 02:07:38.000000000 +0200
-@@ -71,6 +71,7 @@
- PROP_MISC_VOLUME_MANAGEMENT,
- PROP_MISC_CASE_SENSITIVE,
- PROP_MISC_DATE_STYLE,
-+ PROP_MISC_ENABLE_TRASH,
- PROP_MISC_FOLDERS_FIRST,
- PROP_MISC_HORIZONTAL_WHEEL_NAVIGATES,
- PROP_MISC_RECURSIVE_PERMISSIONS,
-@@ -664,6 +665,19 @@
- THUNAR_TYPE_ICON_SIZE,
- THUNAR_ICON_SIZE_SMALLEST,
- EXO_PARAM_READWRITE));
-+
-+ /**
-+ * ThunarPreferences:misc-enable-trash:
-+ *
-+ * If trash is disabled, files will be deleted permanently
-+ **/
-+ g_object_class_install_property (gobject_class,
-+ PROP_MISC_ENABLE_TRASH,
-+ g_param_spec_boolean ("misc-enable-trash",
-+ "misc-enable-trash",
-+ "misc-enable-trash",
-+ TRUE,
-+ EXO_PARAM_READWRITE));
- }
-
-
-diff -ur src/Thunar-1.0.1-orig/thunar/thunar-shortcuts-model.c src/Thunar-1.0.1/thunar/thunar-shortcuts-model.c
---- src/Thunar-1.0.1-orig/thunar/thunar-shortcuts-model.c 2009-01-12 21:38:48.000000000 +0100
-+++ src/Thunar-1.0.1/thunar/thunar-shortcuts-model.c 2009-06-21 12:25:04.000000000 +0200
-@@ -34,6 +34,7 @@
- #include <locale.h>
- #endif
-
-+#include <thunar/thunar-preferences.h>
- #include <thunar/thunar-file.h>
- #include <thunar/thunar-shortcuts-model.h>
- #include <thunar/thunar-private.h>
-@@ -63,7 +64,6 @@
- } ThunarShortcutType;
-
-
--
- static void thunar_shortcuts_model_class_init (ThunarShortcutsModelClass *klass);
- static void thunar_shortcuts_model_tree_model_init (GtkTreeModelIface *iface);
- static void thunar_shortcuts_model_drag_source_init (GtkTreeDragSourceIface *iface);
-@@ -278,6 +278,8 @@
- guint n;
- gchar *desktop_path = NULL;
- guint desktop_index;
-+ gboolean isTrashEnabled;
-+
-
- #ifndef NDEBUG
- model->stamp = g_random_int ();
-@@ -292,6 +294,8 @@
- system_path_list[0] = thunar_vfs_path_get_for_home ();
- system_path_list[1] = thunar_vfs_path_get_for_trash ();
-
-+ g_object_get (G_OBJECT (thunar_preferences_get ()), "misc-enable-trash", &isTrashEnabled, NULL);
-+
- #if GLIB_CHECK_VERSION(2,14,0)
- desktop_path = g_strdup (g_get_user_special_dir (G_USER_DIRECTORY_DESKTOP));
- #else /* GLIB_CHECK_VERSION(2,14,0) */
-@@ -323,6 +327,12 @@
- thunar_vfs_path_unref (system_path_list[n]);
- continue;
- }
-+ /* we exclude the trash */
-+ if (n == 1 && !isTrashEnabled)
-+ {
-+ thunar_vfs_path_unref (system_path_list[n]);
-+ continue;
-+ }
- #endif
-
- /* determine the file for the path */
diff --git a/thunar-notrash/Ability_to_disable_trash_on_Thunar_1.1.6.patch b/thunar-notrash/Ability_to_disable_trash_on_Thunar_1.1.6.patch
new file mode 100644
index 0000000..9fce395
--- /dev/null
+++ b/thunar-notrash/Ability_to_disable_trash_on_Thunar_1.1.6.patch
@@ -0,0 +1,178 @@
+Only in src: Ability_to_disable_trash_on_Thunar_1.1.6.patch
+Only in src2: Ability_to_disable_trash_on_Thunar.patch
+diff -ru src/Thunar-1.1.6/thunar/thunar-application.c src2/Thunar-1.1.6/thunar/thunar-application.c
+--- src/Thunar-1.1.6/thunar/thunar-application.c 2011-01-02 14:35:27.000000000 +0100
++++ src2/Thunar-1.1.6/thunar/thunar-application.c 2011-01-06 16:42:52.000000000 +0100
+@@ -1639,10 +1639,14 @@
+ gchar *message;
+ guint n_path_list = 0;
+ gint response;
++ gboolean isTrashEnabled;
+
+ _thunar_return_if_fail (parent == NULL || GDK_IS_SCREEN (parent) || GTK_IS_WIDGET (parent));
+ _thunar_return_if_fail (THUNAR_IS_APPLICATION (application));
+
++ g_object_get (G_OBJECT (application->preferences), "misc-enable-trash", &isTrashEnabled, NULL);
++ if (!isTrashEnabled)
++ permanently = TRUE;
+ if (!permanently)
+ {
+ /* check if we should permanently delete the files (user holds shift) */
+@@ -1669,8 +1673,8 @@
+ if (G_UNLIKELY (permanently))
+ {
+ /* parse the parent pointer */
+- screen = thunar_util_parse_parent (parent, &window);
+-
++ screen = thunar_util_parse_parent (parent, &window);
++
+ /* generate the question to confirm the delete operation */
+ if (G_LIKELY (n_path_list == 1))
+ {
+Only in src2/Thunar-1.1.6/thunar: thunar-application.c.orig
+Only in src2/Thunar-1.1.6/thunar: thunar-application.c.rej
+Only in src2/Thunar-1.1.6/thunar: .thunar-application.c.un~
+diff -ru src/Thunar-1.1.6/thunar/thunar-preferences.c src2/Thunar-1.1.6/thunar/thunar-preferences.c
+--- src/Thunar-1.1.6/thunar/thunar-preferences.c 2011-01-02 14:35:27.000000000 +0100
++++ src2/Thunar-1.1.6/thunar/thunar-preferences.c 2011-01-06 16:29:57.000000000 +0100
+@@ -71,6 +71,7 @@
+ PROP_MISC_VOLUME_MANAGEMENT,
+ PROP_MISC_CASE_SENSITIVE,
+ PROP_MISC_DATE_STYLE,
++ PROP_MISC_ENABLE_TRASH,
+ PROP_MISC_FOLDERS_FIRST,
+ PROP_MISC_HORIZONTAL_WHEEL_NAVIGATES,
+ PROP_MISC_RECURSIVE_PERMISSIONS,
+@@ -642,6 +643,19 @@
+ THUNAR_TYPE_ICON_SIZE,
+ THUNAR_ICON_SIZE_SMALLEST,
+ EXO_PARAM_READWRITE));
++
++ /**
++ * ThunarPreferences:misc-enable-trash:
++ *
++ * If trash is disabled, files will be deleted permanently
++ **/
++ g_object_class_install_property (gobject_class,
++ PROP_MISC_ENABLE_TRASH,
++ g_param_spec_boolean ("misc-enable-trash",
++ "misc-enable-trash",
++ "misc-enable-trash",
++ TRUE,
++ EXO_PARAM_READWRITE));
+ }
+
+
+Only in src2/Thunar-1.1.6/thunar: thunar-preferences.c.orig
+Only in src2/Thunar-1.1.6/thunar: .thunar-preferences.c.un~
+diff -ru src/Thunar-1.1.6/thunar/thunar-preferences-dialog.c src2/Thunar-1.1.6/thunar/thunar-preferences-dialog.c
+--- src/Thunar-1.1.6/thunar/thunar-preferences-dialog.c 2011-01-02 14:35:27.000000000 +0100
++++ src2/Thunar-1.1.6/thunar/thunar-preferences-dialog.c 2011-01-06 17:17:54.000000000 +0100
+@@ -374,7 +374,7 @@
+ gtk_frame_set_label_widget (GTK_FRAME (frame), label);
+ gtk_widget_show (label);
+
+- table = gtk_table_new (2, 2, FALSE);
++ table = gtk_table_new (3, 2, FALSE);
+ gtk_table_set_row_spacings (GTK_TABLE (table), 6);
+ gtk_table_set_col_spacings (GTK_TABLE (table), 12);
+ gtk_container_set_border_width (GTK_CONTAINER (table), 12);
+@@ -526,7 +526,7 @@
+ gtk_frame_set_label_widget (GTK_FRAME (frame), label);
+ gtk_widget_show (label);
+
+- table = gtk_table_new (2, 2, FALSE);
++ table = gtk_table_new (3, 2, FALSE);
+ gtk_table_set_row_spacings (GTK_TABLE (table), 6);
+ gtk_table_set_col_spacings (GTK_TABLE (table), 12);
+ gtk_container_set_border_width (GTK_CONTAINER (table), 12);
+@@ -553,12 +553,18 @@
+ gtk_box_pack_start (GTK_BOX (vbox), frame, FALSE, TRUE, 0);
+ gtk_widget_show (frame);
+
++ button = gtk_check_button_new_with_mnemonic (_("Move items to Trash on _deletion."));
++ exo_mutual_binding_new (G_OBJECT (dialog->preferences), "misc-enable-trash", G_OBJECT (button), "active");
++ thunar_gtk_widget_set_tooltip (button, _( "By default, items are sent to the Trash on deletion. By disabling this option, items will be removed on deletion and will be lost forever. (DANGEROUS)" ) );
++ gtk_table_attach (GTK_TABLE (table), button, 0,1,2,3, GTK_EXPAND | GTK_FILL, GTK_FILL, 0, 0);
++ gtk_widget_show (button);
++
+ label = gtk_label_new (_("Volume Management"));
+ gtk_label_set_attributes (GTK_LABEL (label), thunar_pango_attr_list_bold ());
+ gtk_frame_set_label_widget (GTK_FRAME (frame), label);
+ gtk_widget_show (label);
+
+- table = gtk_table_new (2, 2, FALSE);
++ table = gtk_table_new (3, 2, FALSE);
+ gtk_table_set_row_spacings (GTK_TABLE (table), 6);
+ gtk_table_set_col_spacings (GTK_TABLE (table), 12);
+ gtk_container_set_border_width (GTK_CONTAINER (table), 12);
+Only in src2/Thunar-1.1.6/thunar: thunar-preferences-dialog.c.orig
+Only in src2/Thunar-1.1.6/thunar: thunar-preferences-dialog.c.rej
+Only in src2/Thunar-1.1.6/thunar: .thunar-preferences-dialog.c.un~
+diff -ru src/Thunar-1.1.6/thunar/thunar-shortcuts-model.c src2/Thunar-1.1.6/thunar/thunar-shortcuts-model.c
+--- src/Thunar-1.1.6/thunar/thunar-shortcuts-model.c 2011-01-02 14:35:27.000000000 +0100
++++ src2/Thunar-1.1.6/thunar/thunar-shortcuts-model.c 2011-01-06 16:41:44.000000000 +0100
+@@ -38,6 +38,7 @@
+ #include <glib.h>
+ #include <glib/gstdio.h>
+
++#include <thunar/thunar-preferences.h>
+ #include <thunar/thunar-file.h>
+ #include <thunar/thunar-shortcuts-model.h>
+ #include <thunar/thunar-private.h>
+@@ -230,11 +231,14 @@
+ GList *system_paths = NULL;
+ GList *volumes;
+ GList *lp;
++ gboolean isTrashEnabled;
+
+ #ifndef NDEBUG
+ model->stamp = g_random_int ();
+ #endif
+
++ g_object_get (G_OBJECT (thunar_preferences_get ()), "misc-enable-trash", &isTrashEnabled, NULL);
++
+ /* connect to the volume monitor */
+ model->volume_monitor = g_volume_monitor_get ();
+ g_signal_connect (model->volume_monitor, "volume-added", G_CALLBACK (thunar_shortcuts_model_volume_added), model);
+@@ -253,7 +257,7 @@
+ g_object_unref (desktop);
+
+ /* append the trash icon if the trash is supported */
+- if (thunar_g_vfs_is_uri_scheme_supported ("trash"))
++ if (isTrashEnabled && thunar_g_vfs_is_uri_scheme_supported ("trash"))
+ system_paths = g_list_append (system_paths, thunar_g_file_new_for_trash ());
+
+ /* append the root file system */
+Only in src2/Thunar-1.1.6/thunar: thunar-shortcuts-model.c.orig
+Only in src2/Thunar-1.1.6/thunar: thunar-shortcuts-model.c.rej
+Only in src2/Thunar-1.1.6/thunar: .thunar-shortcuts-model.c.un~
+diff -ru src/Thunar-1.1.6/thunar/thunar-tree-model.c src2/Thunar-1.1.6/thunar/thunar-tree-model.c
+--- src/Thunar-1.1.6/thunar/thunar-tree-model.c 2011-01-02 14:35:27.000000000 +0100
++++ src2/Thunar-1.1.6/thunar/thunar-tree-model.c 2011-01-06 16:41:54.000000000 +0100
+@@ -282,12 +282,15 @@
+ GList *volumes;
+ GList *lp;
+ GNode *node;
++ gboolean isTrashEnabled;
+
+ /* generate a unique stamp if we're in debug mode */
+ #ifndef NDEBUG
+ model->stamp = g_random_int ();
+ #endif
+
++ g_object_get (G_OBJECT (thunar_preferences_get ()), "misc-enable-trash", &isTrashEnabled, NULL);
++
+ /* initialize the model data */
+ model->sort_case_sensitive = TRUE;
+ model->visible_func = (ThunarTreeModelVisibleFunc) exo_noop_true;
+@@ -320,7 +323,7 @@
+ g_object_unref (desktop);
+
+ /* append the trash icon if the trash is supported */
+- if (thunar_g_vfs_is_uri_scheme_supported ("trash"))
++ if (isTrashEnabled && thunar_g_vfs_is_uri_scheme_supported ("trash"))
+ system_paths = g_list_append (system_paths, thunar_g_file_new_for_trash ());
+
+ /* append the root file system */
+Only in src2/Thunar-1.1.6/thunar: .thunar-tree-model.c.un~
diff --git a/thunar-notrash/PKGBUILD b/thunar-notrash/PKGBUILD
index a024ad4..2992f89 100644
--- a/thunar-notrash/PKGBUILD
+++ b/thunar-notrash/PKGBUILD
@@ -3,42 +3,53 @@
# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
pkgname=thunar-notrash
-pkgver=1.0.2
+pkgver=1.1.6
pkgrel=1
pkgdesc="new modern file manager for Xfce with patch to disable trash"
arch=(i686 x86_64)
-license=('GPL2' 'LGPL2')
+license=('GPL2' 'LGPL2.1')
url="http://thunar.xfce.org"
groups=('xfce4')
conflicts=(thunar)
provides=("thunar=$pkgver")
-depends=('desktop-file-utils' 'libexif>=0.6.19' 'hicolor-icon-theme' 'fam' \
- 'gtk2' 'exo>=0.3.107' 'libxfce4util>=4.6.2' 'hal>=0.5.14' 'libpng' 'libjpeg>=8.0.1' 'startup-notification')
-makedepends=('intltool' 'pkgconfig' 'xfce4-panel>=4.6.4')
-optdepends=('gamin: a fam replacement to make thunar monitor changes to files on the fly')
+depends=('desktop-file-utils' 'libexif' 'hicolor-icon-theme' 'libnotify' 'udev'
+ 'gtk2' 'exo>=0.5.4' 'libxfce4util>=4.7.3' 'libxfce4ui' 'libpng') # 'fam' - obsolete?
+makedepends=('intltool' 'gtk-doc' 'xfce4-panel>=4.7.4')
+optdepends=( # 'gamin: a fam replacement to make thunar monitor changes to files on the fly'
+ 'xfce4-panel: for trash applet'
+ 'tumbler: for thumbnail previews')
options=('!libtool')
-install=${pkgname}.install
-source=(http://archive.xfce.org/src/xfce/thunar/1.0/Thunar-${pkgver}.tar.bz2
- Ability_to_disable_trash_on_Thunar.patch)
+install=thunar-notrash.install
+source=(http://archive.xfce.org/src/xfce/thunar/1.1/Thunar-${pkgver}.tar.bz2
+ Ability_to_disable_trash_on_Thunar_$pkgver.patch)
+md5sums=('a96fdbc0b3d422f864d50374b5d6be41'
+ 'a2c1ccb1148667395bb3e1f27ba9d467')
build() {
cd ${srcdir}/Thunar-${pkgver}
- patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar.patch
+ patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar_$pkgver.patch
- ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --localstatedir=/var --disable-static \
- --disable-gnome-thumbnailers --enable-exif --enable-pcre \
- --disable-wallpaper-plugin
- make || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gio-unix \
+ --enable-dbus \
+ --enable-startup-notification \
+ --enable-gudev \
+ --enable-notifications \
+ --enable-exif \
+ --enable-pcre \
+ --enable-gtk-doc \
+ --disable-debug
+
+ make
}
package() {
cd ${srcdir}/Thunar-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
+ make DESTDIR=${pkgdir} install
sed -i 's:x-directory/gnome-default-handler;::' \
${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
}
-md5sums=('c91073202d373a1f9951a1240083c36d'
- '55816882bbeac5bb1153f0b195a220d7')
-sha1sums=('f7ae00c32402e4bc502aba15477b78e2c558c7c3'
- 'c4b110b2a83b6d7b88e04bb550d20c598ffe6f82')
diff --git a/thunar-notrash/libpng-1.4.patch b/thunar-notrash/libpng-1.4.patch
deleted file mode 100644
index 7f38165..0000000
--- a/thunar-notrash/libpng-1.4.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur Thunar-1.0.1.orig/thunar-vfs/thunar-vfs-thumb.c Thunar-1.0.1/thunar-vfs/thunar-vfs-thumb.c
---- Thunar-1.0.1.orig/thunar-vfs/thunar-vfs-thumb.c 2010-01-20 21:31:35.000000000 -0500
-+++ Thunar-1.0.1/thunar-vfs/thunar-vfs-thumb.c 2010-01-20 21:34:51.000000000 -0500
-@@ -1169,7 +1169,7 @@
- goto done0;
-
- /* verify the png signature */
-- if (G_LIKELY (png_check_sig ((png_bytep) signature, sizeof (signature))))
-+ if (G_LIKELY (!png_sig_cmp ((png_bytep) signature, 0, sizeof (signature))))
- rewind (fp);
- else
- goto done0;