summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-01 11:55:07 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-01 11:55:07 +0100
commit833dcdb1ed487375152a5a66dda0be87f07a066e (patch)
tree4a0ef1154a6ba9eb2392b77bac3dfe85ac51d586
parentf49a0527334a7fc7f41d7b6b97783aac30c9a302 (diff)
downloadaur-packages-833dcdb1ed487375152a5a66dda0be87f07a066e.tar.gz
aur-packages-833dcdb1ed487375152a5a66dda0be87f07a066e.tar.xz
upstream updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--apache/PKGBUILD8
-rw-r--r--vim/PKGBUILD15
-rw-r--r--vim/archlinux.vim2
-rw-r--r--vim/fetch_runtime.sh2
-rw-r--r--vim/vimrc6
-rw-r--r--weechat-git/PKGBUILD73
-rw-r--r--weechat-git/weechatgit.install13
7 files changed, 59 insertions, 60 deletions
diff --git a/apache/PKGBUILD b/apache/PKGBUILD
index f33a7ce..58eec71 100644
--- a/apache/PKGBUILD
+++ b/apache/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=apache
-pkgver=2.2.13
-pkgrel=3
+pkgver=2.2.14
+pkgrel=1
pkgdesc='A high performance Unix-based HTTP server'
arch=('i686' 'x86_64')
options=('!libtool')
@@ -81,3 +81,7 @@ build() {
rm -rf ${pkgdir}/srv/http
rmdir ${pkgdir}/usr/bin
}
+md5sums=('a5226203aaf97e5b941c41a71c112704'
+ 'f4d627c64024c1b7b95efb5ffbaa625e'
+ 'bddd84dafa770d74df1dc1f96bd71823'
+ '3d659d41276ba3bfcb20c231eb254e0c')
diff --git a/vim/PKGBUILD b/vim/PKGBUILD
index c3faac6..d879d73 100644
--- a/vim/PKGBUILD
+++ b/vim/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=vim
_srcver=7.2
-_patchlevel=234
+_patchlevel=267
pkgver=${_srcver}.${_patchlevel}
pkgrel=1
pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor'
arch=(i686 x86_64)
license=('custom:vim')
url="http://www.vim.org"
-depends=('gpm' 'coreutils')
+depends=('gpm' 'coreutils' 'python')
makedepends=('wget' 'sed' 'grep' 'gettext' 'perl')
-optdepends=('perl: the runtime provides a view useful perl scripts')
+optdepends=('perl: the runtime provides a few useful perl scripts')
backup=(etc/vimrc)
install=${pkgname}.install
# we need the extra-stuff to get all patches applied smoothly
@@ -36,7 +36,7 @@ build()
--with-compiledby=ArchLinux --with-features=big \
--enable-gpm --enable-acl --with-x=no --disable-gui \
--enable-multibyte --enable-cscope \
- --enable-perlinterp
+ --enable-perlinterp --enable-pythoninterp
#--with-global-runtime=/usr/share/vim --with-vim-name=vim \
make || return 1
make VIMRCLOC=/etc DESTDIR=${pkgdir} install
@@ -67,3 +67,10 @@ build()
cd ${pkgdir}/usr/share/licenses/vim
ln -s ../../vim/${_versiondir}/doc/uganda.txt license.txt
}
+md5sums=('f0901284b338e448bfd79ccca0041254'
+ '35e04482f07c57221c9a751aaa3b8dac'
+ 'd8884786979e0e520c112faf2e176f05'
+ '6d7e8d7868e8bfaa9a5880cd9c439320'
+ '45c1c3c6aff7de0d8fc2a9d8cd5cec7d'
+ '98a6065e21cba417870a66b78e9f0210'
+ '10353a61aadc3f276692d0e17db1478e')
diff --git a/vim/archlinux.vim b/vim/archlinux.vim
index af7645f..148bb93 100644
--- a/vim/archlinux.vim
+++ b/vim/archlinux.vim
@@ -5,8 +5,6 @@
" NEVER EDIT THIS FILE, IT'S OVERWRITTEN UPON UPGRADES, GLOBAL CONFIGURATION
" SHALL BE DONE IN /etc/vimrc, USER SPECIFIC CONFIGURATION IN ~/.vimrc
-set runtimepath=~/.vim,/usr/share/vim,/usr/share/vim/vimcurrent
-
" Normally we use vim-extensions. If you want true vi-compatibility
" remove change the following statements
set nocompatible " Use Vim defaults instead of 100% vi compatibility
diff --git a/vim/fetch_runtime.sh b/vim/fetch_runtime.sh
index 61c59ae..5825447 100644
--- a/vim/fetch_runtime.sh
+++ b/vim/fetch_runtime.sh
@@ -110,7 +110,7 @@ update_runtime() {
sed -i "/find the end/,+3{s/changelog_date_entry_search/changelog_date_end_entry_search/}" ftplugin/changelog.vim
fi
# make Aaron happy
- wget http://www.vim.org/scripts/download_script.php\?src_id=7766 \
+ wget http://www.vim.org/scripts/download_script.php\?src_id=10872 \
-O autoload/pythoncomplete.vim
cd "${_OLDDIR}"
return 0
diff --git a/vim/vimrc b/vim/vimrc
index 55fbc38..627d028 100644
--- a/vim/vimrc
+++ b/vim/vimrc
@@ -1,5 +1,5 @@
" All system-wide defaults are set in $VIMRUNTIME/archlinux.vim (usually just
-" /usr/share/vim/vimcurrent/archlinux.vim) and sourced by the call to :runtime
+" /usr/share/vim/vimfiles/archlinux.vim) and sourced by the call to :runtime
" you can find below. If you wish to change any of those settings, you should
" do it in this file (/etc/vimrc), since archlinux.vim will be overwritten
" everytime an upgrade of the vim packages is performed. It is recommended to
@@ -11,6 +11,6 @@
runtime! archlinux.vim
-" For more option refer to /usr/share/vim/vimcurrent/vimrc_example.vim or the
-" vim manual
+" For more option refer to /usr/share/vim/vim72/vimrc_example.vim or the vim
+" manual
diff --git a/weechat-git/PKGBUILD b/weechat-git/PKGBUILD
index fd6eaec..6c18c93 100644
--- a/weechat-git/PKGBUILD
+++ b/weechat-git/PKGBUILD
@@ -2,53 +2,48 @@
# Contributor: Tim Zebulla <amon at faumrahrer dot de>
pkgname=weechat-git
-pkgver=20090613
+pkgver=20091022
pkgrel=1
-install=('weechatgit.install')
pkgdesc="Fast, light & extensible IRC client (curses UI)"
arch=('i686' 'x86_64')
url="http://weechat.flashtux.org"
-depends=('perl' 'python>=2.5' 'gnutls' 'lua' 'aspell' 'iksemel' 'ruby<1.9')
+license=('GPL3')
+depends=('aspell' 'iksemel')
makedepends=('git' 'cmake')
-optdepends=('tcl: tcl scripting support')
+optdepends=('tcl: tcl scripting support'
+ 'perl>=5.10: perl scripting support'
+ 'python>=2.6: python scripting support'
+ 'lua: lua scripting support')
+provides=('weechat')
+conflicts=('weechat')
options=(!strip)
-license=('GPL3')
-source=()
-md5sums=()
+install=weechatgit.install
_gitroot="git://git.sv.gnu.org/weechat.git"
-_gitrepo="weechat"
-
-build(){
- cd $startdir/src
-
- msg ""
- msg "Connecting to GIT server..."
-
- if [ ! -d $startdir/src/$_gitrepo ]; then
- msg "First time connected - cloning repo, this may take a while..."
- git clone $_gitroot || return 1
- else
- cd $startdir/src/$_gitrepo
- msg "Updating files..."
- git pull || return 1
- fi
-
- msg "Starting build process..."
-
- cp -r $startdir/src/$_gitrepo $startdir/src/$_gitrepo-build && cd $startdir/src/$_gitrepo-build
-
-# Installs to /usr/local so people can run both stable and devel versions
-# at the same time. Otherwise, change it to /usr
-
- cmake -DCMAKE_BUILD_TYPE=Debug -DDISABLE_DOC=ON -DPREFIX=/usr || return 1
-
- make DESTDIR=${startdir}/pkg install || return 1
-
- rm -r $startdir/src/$_gitrepo-build
-
-}
-
+_gitname="weechat"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ msg "First time connected - cloning repo, this may take a while..."
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting cmake..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ cmake -DCMAKE_BUILD_TYPE=Debug -DDISABLE_RUBY=ON -DDISABLE_DOC=ON -DPREFIX=/usr || return 1
+ make DESTDIR="$pkgdir/" install
+}
# note - to disable an option, use -DDISABLE_JABBER=ON
# this should change soon, and will be -DENABLE_JABBER=OFF
# also, you can see the configure options with ccmake, then just -DOPTIONHERE=ON/OFF
diff --git a/weechat-git/weechatgit.install b/weechat-git/weechatgit.install
index f68d294..be10994 100644
--- a/weechat-git/weechatgit.install
+++ b/weechat-git/weechatgit.install
@@ -1,11 +1,6 @@
post_install() {
- echo "------------------------------------------------------------------------------"
- echo "Warning!"
- echo "It's recommended to use another WeeChat home for testing this version."
- echo "For example:"
- echo "/usr/local/bin/weechat-curses --dir /tmp/weechat"
- echo ""
- echo "You've just built weechat from GIT."
- echo "This is a development version and may therefore be unstable."
- echo "------------------------------------------------------------------------------"
+ echo "------------------------------------------------------------------------------"
+ echo "You've just built weechat from GIT."
+ echo "This is a development version and may therefore be unstable."
+ echo "------------------------------------------------------------------------------"
}