summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-01-22 19:25:52 +0100
committerFlorian Pritz <bluewind@xssn.at>2010-01-22 19:25:52 +0100
commita0c21e79a8608b8db3e3d32a278514a75708207a (patch)
treee5721724ceb15ede823f46e5f6ba8e20b9709135
parent9c3a05dd8ce0a5180b1a47a21ec73bf4ab951ac3 (diff)
downloadaur-packages-a0c21e79a8608b8db3e3d32a278514a75708207a.tar.gz
aur-packages-a0c21e79a8608b8db3e3d32a278514a75708207a.tar.xz
thunar-notrash: fix for new libpng
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--thunar-notrash/PKGBUILD15
-rw-r--r--thunar-notrash/libpng-1.4.patch12
-rw-r--r--thunar-notrash/thunar-vfs-fix-umask.patch11
3 files changed, 34 insertions, 4 deletions
diff --git a/thunar-notrash/PKGBUILD b/thunar-notrash/PKGBUILD
index ac83f3d..cc687f3 100644
--- a/thunar-notrash/PKGBUILD
+++ b/thunar-notrash/PKGBUILD
@@ -18,11 +18,14 @@ optdepends=('gamin: a fam replacement to make thunar monitor changes to files
options=('!libtool')
install=${pkgname}.install
source=(http://www.xfce.org/archive/xfce-4.6.1/src/Thunar-${pkgver}.tar.bz2 Ability_to_disable_trash_on_Thunar.patch
-)
+ thunar-vfs-fix-umask.patch libpng-1.4.patch)
build() {
cd ${srcdir}/Thunar-${pkgver}
patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar.patch
+ patch -p1 < ../libpng-1.4.patch
+ patch -Np0 -i ${srcdir}/thunar-vfs-fix-umask.patch
+
./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
--localstatedir=/var --disable-static \
--disable-gnome-thumbnailers --enable-exif --enable-pcre \
@@ -33,6 +36,10 @@ build() {
${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
}
md5sums=('218373aa45d74b6ba8c69c4d5af3bb19'
- '55816882bbeac5bb1153f0b195a220d7')
-sha256sums=('7a2b6b493463756bbc9c54144fab2f2163bc84f0896b4c06fd225d11025a210d'
- 'e235ac3f5559d685051bb747b348238a925de32653e8e8c9b8b89c1e0bb56a67')
+ '55816882bbeac5bb1153f0b195a220d7'
+ '7247041fd2c411e4a129d3f90350893c'
+ 'ee998c20ba13d0cb18741da8b7d67328')
+sha1sums=('2fcd3a7b0e27b01f059dffc8ffdac94e2b2aa064'
+ 'c4b110b2a83b6d7b88e04bb550d20c598ffe6f82'
+ '47526f997627264813843cf466c5ee9335047458'
+ '99f520655582acb5bffbee72bf0bc37aef37bc69')
diff --git a/thunar-notrash/libpng-1.4.patch b/thunar-notrash/libpng-1.4.patch
new file mode 100644
index 0000000..7f38165
--- /dev/null
+++ b/thunar-notrash/libpng-1.4.patch
@@ -0,0 +1,12 @@
+diff -Naur Thunar-1.0.1.orig/thunar-vfs/thunar-vfs-thumb.c Thunar-1.0.1/thunar-vfs/thunar-vfs-thumb.c
+--- Thunar-1.0.1.orig/thunar-vfs/thunar-vfs-thumb.c 2010-01-20 21:31:35.000000000 -0500
++++ Thunar-1.0.1/thunar-vfs/thunar-vfs-thumb.c 2010-01-20 21:34:51.000000000 -0500
+@@ -1169,7 +1169,7 @@
+ goto done0;
+
+ /* verify the png signature */
+- if (G_LIKELY (png_check_sig ((png_bytep) signature, sizeof (signature))))
++ if (G_LIKELY (!png_sig_cmp ((png_bytep) signature, 0, sizeof (signature))))
+ rewind (fp);
+ else
+ goto done0;
diff --git a/thunar-notrash/thunar-vfs-fix-umask.patch b/thunar-notrash/thunar-vfs-fix-umask.patch
new file mode 100644
index 0000000..dbfc1f8
--- /dev/null
+++ b/thunar-notrash/thunar-vfs-fix-umask.patch
@@ -0,0 +1,11 @@
+--- thunar-vfs/thunar-vfs-io-jobs.c.orig 2009-05-19 18:44:00.000000000 +0100
++++ thunar-vfs/thunar-vfs-io-jobs.c 2009-05-19 18:46:04.000000000 +0100
+@@ -708,7 +708,7 @@
+ _thunar_vfs_job_process_path (job, lp);
+
+ /* try to create the target directory */
+- if (!_thunar_vfs_io_ops_mkdir (lp->data, 0777 & ~umask(0), THUNAR_VFS_IO_OPS_NONE, error))
++ if (!_thunar_vfs_io_ops_mkdir (lp->data, 0777, THUNAR_VFS_IO_OPS_NONE, error))
+ return FALSE;
+ }
+