summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
commitf0d152ea0fe92423f39a487e97908d409f98047b (patch)
tree6396fb8e6a851f46f0cfc978c4720b3d2c3726b5
parent4955b0d9fc05950c5794c9cc37923deb00e9cfa5 (diff)
downloadaur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.gz
aur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.xz
some updates again
-rw-r--r--dovecot-sieve/PKGBUILD22
-rw-r--r--dovecot/-1.2.1.tar.gz.part0
-rw-r--r--dovecot/PKGBUILD51
-rw-r--r--dovecot/dovecot-managesieve-1.2.1.tar.gz.part0
-rw-r--r--dovecot/dovecot-managesieve.install26
-rw-r--r--dovecot/dovecot.sh36
-rw-r--r--fortune-mod-issa-haiku/PKGBUILD18
-rw-r--r--highlight/PKGBUILD20
-rw-r--r--libowfat/PKGBUILD21
-rw-r--r--libowfat/libowfat.install39
-rw-r--r--munin-node/Makefile.config106
-rw-r--r--munin-node/PKGBUILD32
-rw-r--r--munin-node/munin-node.finish18
-rw-r--r--munin-node/munin-node.init38
-rw-r--r--munin-node/munin-node.install34
-rw-r--r--munin-node/munin-node.runit23
-rw-r--r--murmur/PKGBUILD45
-rw-r--r--murmur/murmur-config.sh134
-rw-r--r--murmur/murmur.install35
-rw-r--r--murmur/murmurd40
-rw-r--r--opentracker/PKGBUILD54
-rw-r--r--opentracker/license.txt2
-rw-r--r--opentracker/opentracker.rc.d37
-rw-r--r--perl-file-next/ChangeLog23
-rw-r--r--perl-file-next/PKGBUILD27
25 files changed, 881 insertions, 0 deletions
diff --git a/dovecot-sieve/PKGBUILD b/dovecot-sieve/PKGBUILD
new file mode 100644
index 0000000..642ec67
--- /dev/null
+++ b/dovecot-sieve/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Paul Ezvan <paul@ezvan.fr>
+pkgname=dovecot-sieve
+pkgver=0.1.9
+pkgrel=1
+_dovecotver=1.2.4
+_dovecotvers=1.2
+pkgdesc="Dovecot sieve plugin"
+arch=('i686' 'x86_64')
+url="http://wiki.dovecot.org/LDA/Sieve"
+license=('LGPL')
+depends=("dovecot=$_dovecotver")
+source=(http://www.rename-it.nl/dovecot/$_dovecotvers/dovecot-$_dovecotvers-sieve-$pkgver.tar.gz)
+md5sums=('a9a9254def9e9a05105aa56a960ac7fa')
+
+build() {
+
+ cd "$srcdir/dovecot-$_dovecotvers-sieve-$pkgver" || return 1
+
+ ./configure --prefix=/usr --with-dovecot=/usr/lib/dovecot || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
diff --git a/dovecot/-1.2.1.tar.gz.part b/dovecot/-1.2.1.tar.gz.part
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/dovecot/-1.2.1.tar.gz.part
diff --git a/dovecot/PKGBUILD b/dovecot/PKGBUILD
new file mode 100644
index 0000000..0421f9f
--- /dev/null
+++ b/dovecot/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+#
+# Contributor: Paul Mattal <paul@mattal.com>
+# Contributor: Federico Quagliata (quaqo) <quaqo@despammed.com>
+# Contributor: GARETTE Emmanuel <gnunux at laposte dot net>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=dovecot-managesieve
+_pkgname=dovecot
+pkgver=1.2.1
+_patchver=0.11.7
+pkgrel=1
+pkgdesc="An IMAP and POP3 server written with security primarily in mind"
+arch=('i686' 'x86_64')
+url="http://dovecot.org/"
+license=("LGPL")
+depends=("pam>=1.0.4" "libmysqlclient>=5.1.35-2" "postgresql-libs>=8.3.7" "sqlite3>=3.6.15-2" "db>=4.7.25.4"\
+ "heimdal>=1.2.1-5" 'libcap>=2.16-3' 'bzip2')
+optdepends=('libldap: ldap plugin')
+makedepends=('libldap>=2.3.43-3')
+provides=('imap-server' 'pop3-server')
+replaces=()
+options=('!libtool')
+install=$pkgname.install
+source=(http://dovecot.org/releases/1.2/${_pkgname}-${pkgver}.tar.gz dovecot.sh "http://www.rename-it.nl/dovecot/1.2/${_pkgname}-${pkgver}-managesieve-${_patchver}.diff.gz")
+md5sums=('c269cfe38fc40061e232dd28e5fe3721'
+ 'd020d43eab4ded6fb379dadc570a9490')
+
+build() {
+ cd ${srcdir}/${_pkgname}-$pkgver || return 1
+
+ patch -p1 < $srcdir/${_pkgname}-${pkgver}-managesieve-${_patchver}.diff || return 1
+
+ # configure with openssl, mysql, and postgresql support
+ ./configure --prefix=/usr --sysconfdir=/etc/dovecot --localstatedir=/var \
+ --libexecdir=/usr/lib --with-moduledir=/usr/lib/dovecot/modules \
+ --with-db --with-mysql --with-pgsql --with-sqlite \
+ --with-ssl=openssl --with-ssldir=/etc/dovecot/ssl \
+ --with-gssapi --with-ldap=plugin --enable-header-install --with-docs || return 1
+
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+
+ # install the launch script
+ install -D -m755 ${srcdir}/${_pkgname}.sh ${pkgdir}/etc/rc.d/${_pkgname} || return 1
+
+ # fix paths in the config example file where we have a different layout
+ sed -i 's|/usr/lib/dovecot|/usr/lib/dovecot/modules|g;
+ s|libexec|lib|g;
+ s|lib/sendmail|sbin/sendmail|g' $pkgdir/etc/dovecot/dovecot-example.conf || return 1
+}
diff --git a/dovecot/dovecot-managesieve-1.2.1.tar.gz.part b/dovecot/dovecot-managesieve-1.2.1.tar.gz.part
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/dovecot/dovecot-managesieve-1.2.1.tar.gz.part
diff --git a/dovecot/dovecot-managesieve.install b/dovecot/dovecot-managesieve.install
new file mode 100644
index 0000000..5175734
--- /dev/null
+++ b/dovecot/dovecot-managesieve.install
@@ -0,0 +1,26 @@
+# arg 1: the new package version
+post_install() {
+ if [ -z "`grep '^dovecot:' /etc/group`" ]; then
+ groupadd -g 76 dovecot >& /dev/null
+ fi
+ if [ -z "`grep '^dovecot:' /etc/passwd`" ]; then
+ useradd -u 76 -d /var/run/dovecot/login -g dovecot -s /bin/false dovecot
+ fi
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ userdel dovecot &> /dev/null
+ groupdel dovecot &> /dev/null
+}
+
+op=$1
+shift
+
+$op $*
diff --git a/dovecot/dovecot.sh b/dovecot/dovecot.sh
new file mode 100644
index 0000000..b7555fe
--- /dev/null
+++ b/dovecot/dovecot.sh
@@ -0,0 +1,36 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/dovecot`
+case "$1" in
+ start)
+ stat_busy "Starting Dovecot"
+ [ -z "$PID" ] && /usr/sbin/dovecot
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon dovecot
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping Dovecot"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon dovecot
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 2
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0
diff --git a/fortune-mod-issa-haiku/PKGBUILD b/fortune-mod-issa-haiku/PKGBUILD
new file mode 100644
index 0000000..49284fa
--- /dev/null
+++ b/fortune-mod-issa-haiku/PKGBUILD
@@ -0,0 +1,18 @@
+# Contributor: Samhain
+
+pkgname=fortune-mod-issa-haiku
+pkgver=1.1
+pkgrel=2
+pkgdesc="Fortune cookies: Kobayashi Issa's haiku collection (7000+)"
+arch=(i686 x86_64)
+license=(public domain)
+depends=(fortune-mod)
+source="http://www.tastyrabbit.net/issa-haiku.tar.gz"
+url="http://www.tastyrabbit.net/2008/05/archlinux-fortune-cookie-haiku-package.html"
+md5sums=('6418f81836f0323227b42a68292be806')
+
+build() {
+ cd $startdir/src
+ mkdir -p $startdir/pkg/usr/share/fortune
+ cp issa-haiku issa-haiku.dat $startdir/pkg/usr/share/fortune
+}
diff --git a/highlight/PKGBUILD b/highlight/PKGBUILD
new file mode 100644
index 0000000..de11471
--- /dev/null
+++ b/highlight/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Jan Fader <jan.fader@web.de>
+pkgname=highlight
+pkgver=2.11
+pkgrel=1
+pkgdesc="Highlight converts sourcecode to HTML, XHTML, RTF, LaTeX, TeX, XML and terminal escape sequences with coloured syntax highlighting. Language definitions, colour themes and indentation schemes are customizable"
+url="http://www.andre-simon.de/doku/highlight/highlight.html"
+license=('GPL')
+arch=('i686' 'x86_64')
+install=
+source=(http://www.andre-simon.de/zip/$pkgname-$pkgver.tar.bz2)
+md5sums=('c0f9d4b2b5d1557f218d85929244f036')
+
+build() {
+ cd "$startdir/src/$pkgname-$pkgver"
+
+ make || return 1
+ make DESTDIR="$startdir/pkg" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/libowfat/PKGBUILD b/libowfat/PKGBUILD
new file mode 100644
index 0000000..6b3dffe
--- /dev/null
+++ b/libowfat/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Alexander Ulrich <a.ulrich@student.uni-tuebingen.de>
+# Update: Mildred <silkensedai@online.fr>
+# Update: henning mueller <henning@orgizm.net>
+pkgname=libowfat
+pkgver=0.28
+pkgrel=1
+pkgdesc="GPL reimplementation of libdjb"
+arch=(i686 x86_64)
+url=http://www.fefe.de/libowfat/
+license=(GPL)
+install=libowfat.install
+source=(http://dl.fefe.de/$pkgname-$pkgver.tar.bz2)
+md5sums=(6bbee9a86506419657d87123b7a6f2c1)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver/
+ make DIET= || return 1
+ make prefix=$startdir/pkg/usr/ LIBDIR=$startdir/pkg/usr/lib install
+ cd $startdir/pkg/usr/man/man3
+ mv buffer.3 buffer-libowfat.3
+}
diff --git a/libowfat/libowfat.install b/libowfat/libowfat.install
new file mode 100644
index 0000000..a08aef1
--- /dev/null
+++ b/libowfat/libowfat.install
@@ -0,0 +1,39 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo "The manpage buffer(3) was moved to buffer-libowfat(3) because
+ it conflicts with package openssl"
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*
diff --git a/munin-node/Makefile.config b/munin-node/Makefile.config
new file mode 100644
index 0000000..9542429
--- /dev/null
+++ b/munin-node/Makefile.config
@@ -0,0 +1,106 @@
+# This file specifies where Munin will look for things after you've
+# run 'make' in the source directory. Modify it to suit your needs.
+
+# DESTDIR is empty during building, and optionally set to point to
+# a shadow tree during make install.
+
+#
+# the base of the Munin installation.
+#
+PREFIX = $(DESTDIR)
+
+# Where Munin keeps its configurations (server.conf, client.conf, ++)
+CONFDIR = $(DESTDIR)/etc/munin
+
+# Server only - where to put munin-cron
+BINDIR = $(PREFIX)/usr/bin
+
+# Client only - where to put munin-node, munin-node-configure, and munin-run
+SBINDIR = $(PREFIX)/sbin
+
+# Where to put text and html documentation
+DOCDIR = $(PREFIX)/usr/share/doc/munin
+
+# Where to put man pages
+MANDIR = $(PREFIX)/usr/share/man
+
+# Where to put internal binaries and plugin repository
+LIBDIR = $(PREFIX)/usr/lib/munin
+
+# Server only - Output directory
+HTMLDIR = $(PREFIX)/srv/http/munin
+CGIDIR = $(HTMLDIR)/cgi
+
+# Client only - Where to put RRD files and other intenal data
+DBDIR = $(DESTDIR)/var/munin
+
+# Client only - Where plugins should put their states. Must be writable by
+# group "munin", and should be preserved between reboots
+PLUGSTATE = $(DBDIR)/plugin-state
+
+# Where Munin should place its logs.
+LOGDIR = $(DESTDIR)/var/log/munin
+
+# Location of PID files and other statefiles. On the server, must be
+# writable by the user "munin".
+STATEDIR = $(DESTDIR)/var/run/munin
+
+# The perl interpreter to use
+PERL = $(shell which perl)
+
+# The python interpreter to use (used by some plugins)
+PYTHON = /usr/bin/env python
+
+# A modern (posix) shell. We're not looking for arrays, but $() and
+# other modern stuff is expected. On a posix-system the expression
+# below will find the right shell. Most Unixes released the last 10
+# years are POSIX compliant enough for this to work (he said bravely).
+#
+# On Linux /bin/sh, SunOS/Solaris /usr/xpg4/bin/sh or /bin/ksh
+# In general: bash or ksh will work
+#
+GOODSH = $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
+
+# Path of bash for bash specific plugins
+BASH = /bin/bash
+
+# Server only - Where to install the perl libraries
+PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
+
+# Client only - Install plugins for this architecture
+OSTYPE = $(shell uname | tr '[A-Z]' '[a-z]')
+
+# How to figure out the hostname. (Only used in default configuration
+# files)
+HOSTNAME = $(shell hostname)
+
+# What is the safest way to create a tempfile.
+# Default is to figure it out by testing various methods.
+# Replace this with a known platform-specific method
+MKTEMP = $(shell ./test-mktemp)
+
+# Munin version number.
+VERSION = $(shell cat RELEASE)
+
+# User to run munin as
+USER = munin
+GROUP = munin
+
+# Default user to run the plugins as
+PLUGINUSER = nobody
+
+# Which command to use to check if the USER and GROUP to run Munin as, exists.
+GETENT = $(shell which true 2>/dev/null)
+CHECKUSER = $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
+CHECKGROUP = $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
+
+# For OSX, comment out the previous two lines and comment in these
+#CHECKUSER = $(shell nicl . -read /users/$(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
+#CHECKGROUP = $(shell nicl . -read /groups/$(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
+
+CHOWN = true
+CHMOD = chmod
+CHGRP = true
+# Check whether setruid functionality can be used
+HASSETR = $(shell perl -e 'use Config; my @vars=("d_setruid", "d_setreuid", "d_setresuid"); foreach my $$var (@vars) { if ($$Config{$$var} eq "define") { print "1\n"; exit 0; } } print "0\n"; exit 0;' )
+
diff --git a/munin-node/PKGBUILD b/munin-node/PKGBUILD
new file mode 100644
index 0000000..de756a4
--- /dev/null
+++ b/munin-node/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Roberto Alsina <ralsina@kde.org>
+pkgname=munin-node
+pkgver=1.2.6
+pkgrel=12
+pkgdesc="A distributed monitoring/graphing agent"
+arch=('i686' 'x86_64')
+url="http://munin.sf.net"
+license=("GPL")
+depends=(perl perl-net-server which)
+backup=(etc/munin/munin-node.conf)
+install=munin-node.install
+source=(http://downloads.sourceforge.net/sourceforge/munin/munin_$pkgver.tar.gz \
+ Makefile.config munin-node.init munin-node.runit munin-node.finish munin-node.install)
+
+md5sums=('45f84d58f80642ce914f147232f0d396' '686cef93dee285949a0451c81b691085'\
+ '14872c731f99d5f9d831115b2f5e282e' '422000b064a03023b8dee2c76eee0548'\
+ '39eb25fec876123cff9c6927d4a9d46a' 'aa8e338183ae2f4602bcaedfc6ca8927')
+
+build() {
+cd $srcdir/munin-$pkgver
+cp $srcdir/Makefile.config $srcdir/munin-$pkgver || exit 1
+
+make PREFIX='' || exit 1
+make DESTDIR=$pkgdir install-node install-node-plugins || exit 1
+
+sed -i "s|\$ENV{'MUNIN_HOSTNAME'}.*|\$ENV{'MUNIN_HOSTNAME'} = \`hostname\`;|g" $pkgdir/sbin/munin-node
+sed -i "s|\$ENV{'MUNIN_HOSTNAME'}.*|\$ENV{'MUNIN_HOSTNAME'} = \`hostname\`;|g" $pkgdir/sbin/munin-run
+
+install -D -m0755 -o root ../munin-node.init $pkgdir/etc/rc.d/munin-node
+install -D -m0755 -o root ../munin-node.runit $pkgdir/etc/munin-node/run
+install -D -m0755 -o root ../munin-node.finish $pkgdir/etc/munin-node/finish
+}
diff --git a/munin-node/munin-node.finish b/munin-node/munin-node.finish
new file mode 100644
index 0000000..934ad4a
--- /dev/null
+++ b/munin-node/munin-node.finish
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+BIN=/sbin/munin-node
+OPTS=""
+SVC=munin-node
+
+echo "Stopping $SVC daemon"
+PID=`pidof $BIN`
+if [ -z "$PID" ]
+then
+rm -f /var/run/munin/$SVC.pid
+rm_daemon $SVC
+fi
+
diff --git a/munin-node/munin-node.init b/munin-node/munin-node.init
new file mode 100644
index 0000000..e62b43b
--- /dev/null
+++ b/munin-node/munin-node.init
@@ -0,0 +1,38 @@
+#!/bin/sh
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /sbin/munin-node`
+
+case "$1" in
+ start)
+ stat_busy "Starting munin-node"
+ /sbin/munin-node >/dev/null
+ stat_done
+ ;;
+ stop)
+ stat_busy "Stopping munin-node"
+ if [ ! -z "$PID" ]; then
+ kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ exit 1
+ else
+ rm -f /var/run/munin/munin-node.pid &>/dev/null
+ stat_done
+ fi
+ else
+ stat_fail
+ exit 1
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+ ;;
+esac
diff --git a/munin-node/munin-node.install b/munin-node/munin-node.install
new file mode 100644
index 0000000..2f190f4
--- /dev/null
+++ b/munin-node/munin-node.install
@@ -0,0 +1,34 @@
+# arg 1: the new package version
+post_install () {
+
+# Check user/group munin exists
+
+ getent group munin > /dev/null || groupadd munin
+ getent passwd munin > /dev/null || useradd -c "Munin system monitor" -g munin -s /bin/false -d /var/munin munin
+
+# Fix permissions
+ chown munin.munin -R /var/log/munin /var/munin /var/run/munin
+
+
+# Do basic configuration
+
+ echo "==> Configuring default plugins for this system"
+ /sbin/munin-node-configure --shell | sh
+
+ echo "==> To use the SNMP plugins you will need perl-net-snmp"
+
+}
+
+pre_remove() {
+
+# Only remove the user if munin is not installed,
+# because both packages need this user
+ killall munin-node
+ pacman -Q munin >& /dev/null || ( /usr/sbin/userdel munin >& /dev/null ; \
+ /usr/sbin/groupdel munin >& /dev/null )
+}
+
+op=$1
+shift
+
+$op $*
diff --git a/munin-node/munin-node.runit b/munin-node/munin-node.runit
new file mode 100644
index 0000000..60156e9
--- /dev/null
+++ b/munin-node/munin-node.runit
@@ -0,0 +1,23 @@
+#!/bin/sh
+exec 2>&1
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+BIN=/sbin/munin-node
+OPTS=""
+SVC=munin-node
+
+PID=`pidof $BIN`
+if [ -z "$PID" ]
+then
+ if [ -f /var/run/munin/$SVC.pid ]
+ then
+ rm /var/run/munin/$SVC.pid
+ rm_daemon $SVC
+ fi
+ echo "Starting $SVC daemon"
+ $BIN $OPTS
+else
+ [ -z $PID ] || exec watchpid $PID
+fi
diff --git a/murmur/PKGBUILD b/murmur/PKGBUILD
new file mode 100644
index 0000000..bc5ee00
--- /dev/null
+++ b/murmur/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Sebastian.Salich@gmx.de
+# Maintainer: Doc Angelo
+
+pkgname=murmur
+pkgver=1.1.8
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="The voice chat application server for Mumble"
+license=('GPL')
+backup=('etc/murmurd.ini')
+depends=('qt>=4.4.0' 'libcap')
+makedepends=('pkgconfig')
+conflicts=('mumble<=1.1.4' 'mumble-server')
+options=('!libtool')
+url="http://mumble.sourceforge.net/"
+source=("http://downloads.sourceforge.net/mumble/mumble-$pkgver.tar.gz" \
+ murmurd \
+ murmur.install \
+ murmur-config.sh)
+md5sums=('a7da012922d39b87c45d9f481d4b5efb'
+ 'e3c7be4cc45ff64a7b9e36605ac24497'
+ '5a9f17491006e979037ac148a3881fe2'
+ 'ceb7bf98b02ce49837b2ea7640c4b68d')
+install=murmur.install
+
+build() {
+ cd $srcdir/mumble-$pkgver
+
+ # Building murmur
+ /usr/bin/qmake main.pro "CONFIG+=no-client no-ice" || exit 1
+ make || exit 1
+
+ # create directories and copy files
+ install -m755 -D $startdir/murmurd $pkgdir/etc/rc.d/murmurd
+ install -m755 -D $startdir/murmur-config.sh $pkgdir/usr/bin/murmur-config.sh
+ install -m755 -D ./release/murmurd $pkgdir/usr/sbin/murmurd
+ install -m755 -d $pkgdir/usr/share/man/man1
+ install -m644 -D ./man/mur* $pkgdir/usr/share/man/man1/
+ install -m755 -d $pkgdir/var/lib/murmurd
+
+ # copy and modify murmurd.ini
+ sed 's|database=|database=/var/lib/murmurd/murmurd.sqlite|g;s|#logfile=murmur.log|logfile=/var/log/murmurd.log|g' ./scripts/murmur.ini > ./scripts/murmurd.ini
+ install -m644 -D ./scripts/murmurd.ini $pkgdir/etc/
+ rm ./scripts/murmurd.ini
+}
diff --git a/murmur/murmur-config.sh b/murmur/murmur-config.sh
new file mode 100644
index 0000000..ebee4a4
--- /dev/null
+++ b/murmur/murmur-config.sh
@@ -0,0 +1,134 @@
+#!/bin/bash
+#
+# -> config.sh
+#
+# version: 1.1
+# author: Massimo Mund
+# date: 21.12.2007
+# description: a script to easily add, remove and edit users from a murmur server
+#
+
+#information
+version="1.1"
+
+#settings
+bin="sqlite3"
+dbfile="/var/lib/murmurd/murmurd.sqlite"
+
+function checkforsqlite() {
+
+ if [ ! -f /usr/bin/sqlite3 ]; then
+ echo "it seems that there is no sqlite3 installed, which is necessary for this script! "
+ echo "install sqlite3 and try it again!"
+ exit
+ fi
+
+}
+
+function help () {
+
+ echo ""
+ echo " usage: config.sh <cmd> | --help | --version"
+ echo ""
+ echo " commands:"
+ echo " showusers"
+ echo " adduser <username> <pw> [<serverid>] [<email>]"
+ echo " deluser <username> [<serverid>]"
+ echo " setpw <username> <newpw> [<serverid>]"
+ echo " setemail <username> <newemail> [<serverid>]"
+ echo ""
+ exit
+
+}
+
+function version() {
+
+ echo "config.sh : version: $1"
+ exit
+}
+
+function invalidoption () {
+
+ echo "config.sh : invalid option -- $*"
+ echo "Try 'config.sh --help' for more information."
+ exit
+
+}
+
+checkforsqlite
+
+while [ "$#" -gt "0" ]; do
+ case $1 in
+ showusers)
+ $bin $dbfile "select * from players;"
+ exit
+ ;;
+ adduser)
+ shift
+ username="$1"
+ email="$4"
+ pw="$2"
+ serverid="$3"
+ playerid=$($bin $dbfile "select MAX(player_id)+1 as id from players WHERE player_id < 10000;")
+
+ if [ "$serverid" == "" ]; then
+ serverid="1"
+ fi
+
+ $bin $dbfile "insert into players (server_id, player_id, name, email, pw) values($serverid, $playerid, '$username', '$email', '$pw');"
+ exit
+ ;;
+ deluser)
+ shift
+ username="$1"
+ serverid="$2"
+
+ if [ "$serverid" == "" ]; then
+ serverid="1"
+ fi
+
+ $bin $dbfile "delete from players where name='$username';"
+ exit
+ ;;
+ setpw)
+ shift
+ username="$1"
+ newpw="$2"
+ serverid="$3"
+
+ if [ "$serverid" == "" ]; then
+ serverid="1"
+ fi
+
+ $bin $dbfile "update players set pw='$newpw' where name='$username';"
+ exit
+ ;;
+ setemail)
+ shift
+ username="$1"
+ newemail="$2"
+ serverid="$3"
+
+ if [ "$serverid" == "" ]; then
+ serverid="1"
+ fi
+
+ $bin $dbfile "update players set email='$newemail' where name='$username';"
+ exit
+ ;;
+ --help)
+ help
+ ;;
+ --version)
+ version $version
+ ;;
+ *)
+ invalidoption $*
+ break
+ ;;
+ esac
+done
+
+invalidoption $*
+
+exit 0
diff --git a/murmur/murmur.install b/murmur/murmur.install
new file mode 100644
index 0000000..d940c64
--- /dev/null
+++ b/murmur/murmur.install
@@ -0,0 +1,35 @@
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+post_install() {
+ echo ' -> The user SuperUser has a blank password! You can change'
+ echo ' -> this and administrate users with murmur-config.sh.'
+ echo ''
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*
+ \ No newline at end of file
diff --git a/murmur/murmurd b/murmur/murmurd
new file mode 100644
index 0000000..630b49f
--- /dev/null
+++ b/murmur/murmurd
@@ -0,0 +1,40 @@
+#!/bin/bash
+
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/murmurd`
+
+case "$1" in
+ start)
+ stat_busy "Starting Murmur Server"
+ [ -z $PID ] && /usr/sbin/murmurd -ini /etc/murmurd.ini & > /dev/null 2>&1
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ PID=`pidof -o %PPID /usr/sbin/murmurd`
+ echo $PID >/var/run/murmurd.pid
+ add_daemon murmurd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping Murmur Server"
+ [ ! -z $PID ] && kill $PID & > /dev/null 2>&1
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon murmurd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 3
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0
diff --git a/opentracker/PKGBUILD b/opentracker/PKGBUILD
new file mode 100644
index 0000000..fef8a6f
--- /dev/null
+++ b/opentracker/PKGBUILD
@@ -0,0 +1,54 @@
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=opentracker
+pkgver=20090222
+pkgrel=1
+pkgdesc='An open and free bittorrent tracker'
+arch=('i686' 'x86_64')
+url='http://erdgeist.org/arts/software/opentracker/'
+license=('custom' 'GPL')
+makedepends=('libowfat' 'cvs')
+depends=('bash' 'zlib')
+backup=('etc/opentracker/config')
+source=('opentracker.rc.d' 'license.txt')
+md5sums=('390bde9d010e79ab1309c02dcf9972e8'
+ '865211941e882c0aff5d36a22ac9efaa')
+
+_cvsroot=':pserver:anoncvs@cvs.erdgeist.org:/home/cvsroot'
+_cvsmod='opentracker'
+
+build() {
+ cd "$srcdir"
+ msg 'Connecting to CVS server....'
+ if [ -d $_cvsmod/CVS ]; then
+ cd $_cvsmod
+ cvs -z3 update -d
+ else
+ cvs -z3 -d $_cvsroot co -D $pkgver -f $_cvsmod
+ cd $_cvsmod
+ fi
+
+ msg 'CVS checkout done or server timeout'
+ msg 'Starting make...'
+
+ rm -rf "$srcdir/$_cvsmod-build"
+ cp -r "$srcdir/$_cvsmod" "$srcdir/$_cvsmod-build"
+ cd "$srcdir/$_cvsmod-build"
+
+ sed -e 's#PREFIX?=..#PREFIX?=/usr#' \
+ -e 's#LIBOWFAT_HEADERS=$(PREFIX)/libowfat#LIBOWFAT_HEADERS=$(PREFIX)/include#' \
+ -e 's#LIBOWFAT_LIBRARY=$(PREFIX)/libowfat#LIBOWFAT_LIBRARY=$(PREFIX)/lib#' \
+ -e 's/#FEATURES+=-DWANT_ACCESSLIST_WHITE/FEATURES+=-DWANT_ACCESSLIST_WHITE/' \
+ -e 's/#FEATURES+=-DWANT_RESTRICT_STATS/FEATURES+=-DWANT_RESTRICT_STATS/' \
+ -e 's/FEATURES+=-DWANT_FULLSCRAPE/#FEATURES+=-DWANT_FULLSCRAPE/' \
+ -i Makefile
+ sed -e 's|# tracker.rootdir /usr/local/etc/opentracker|tracker.rootdir /etc/opentracker|' \
+ -e 's|# access.stats 192.168.0.23|access.stats 127.0.0.1|' \
+ -i opentracker.conf.sample
+
+ make || return 1
+ install -D -m 755 opentracker $pkgdir/usr/bin/opentracker
+ install -D -m 755 $srcdir/opentracker.rc.d $pkgdir/etc/rc.d/opentracker
+ install -D -m 644 opentracker.conf.sample $pkgdir/etc/opentracker/config
+ install -D -m 644 $srcdir/license.txt $pkgdir/usr/share/licenses/opentracker/license.txt
+}
diff --git a/opentracker/license.txt b/opentracker/license.txt
new file mode 100644
index 0000000..ff1bb40
--- /dev/null
+++ b/opentracker/license.txt
@@ -0,0 +1,2 @@
+This software was written by Dirk Engling <erdgeist@erdgeist.org>
+It is considered beerware. Prost. Skol. Cheers or whatever.
diff --git a/opentracker/opentracker.rc.d b/opentracker/opentracker.rc.d
new file mode 100644
index 0000000..b1aa34c
--- /dev/null
+++ b/opentracker/opentracker.rc.d
@@ -0,0 +1,37 @@
+#!/bin/bash
+
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/bin/opentracker`
+
+case "$1" in
+ start)
+ stat_busy "Starting opentracker Daemon"
+ [ -z "$PID" ] && su nobody -s /bin/sh -c "/usr/bin/opentracker -f /etc/opentracker/config&"
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon opentracker
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping opentracker Daemon"
+ [ ! -z "$PID" ] && kill $PID &>/dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon opentracker
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
diff --git a/perl-file-next/ChangeLog b/perl-file-next/ChangeLog
new file mode 100644
index 0000000..8d57268
--- /dev/null
+++ b/perl-file-next/ChangeLog
@@ -0,0 +1,23 @@
+2009-08-05 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.06-1 :
+ Updated to the latest version.
+ Changed to arch=('any')
+
+
+2009-07-31 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.04-1 :
+ Updated to the latest version.
+
+
+2009-05-21 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.02-2 :
+ Replaced in my '# Contributor:' line by '# Maintainer:'
+
+
+2009-03-02 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.02-1 :
+ Initial release
diff --git a/perl-file-next/PKGBUILD b/perl-file-next/PKGBUILD
new file mode 100644
index 0000000..53fe9a6
--- /dev/null
+++ b/perl-file-next/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+pkgname=perl-file-next
+_pkgname=File-Next
+pkgver=1.06
+pkgrel=1
+pkgdesc='File::Next - File-finding iterator'
+arch=('any')
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/dist/${_pkgname}"
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+
+source=(http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE/${_pkgname}-$pkgver.tar.gz)
+md5sums=('8d901b18e40c477acd18a6ea0fd7de64')
+
+build() {
+ cd $srcdir/${_pkgname}-$pkgver
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+
+ make || return 1
+ make install DESTDIR=$pkgdir || return 1
+
+ find $pkgdir -name perllocal.pod -delete
+ find $pkgdir -name .packlist -delete
+}